Closed Bug 1855685 Opened 7 months ago Closed 6 months ago

Inline preview bookmarks are treated as regular source code tokens

Categories

(DevTools :: Debugger, defect, P2)

defect

Tracking

(firefox-esr115 unaffected, firefox118 unaffected, firefox119 fixed, firefox120 fixed)

RESOLVED FIXED
120 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox118 --- unaffected
firefox119 --- fixed
firefox120 --- fixed

People

(Reporter: nchevobbe, Assigned: bomsy, NeedInfo)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

See screenshot

mozregression gave me this range: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e5cda9112336dc953a11c0cd0403690ca54ba077&tochange=2ea4fd5d517a2b5edf081c9e2ccd8c014f6dc171 , so the regression might be from Bug 1851522 too (but Bug 1851566 did modified the preview action, so it's more likely)

Set release status flags based on info from the regressing bug 1851566

:ochameau, since you are the author of the regressor, bug 1851566, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(poirot.alex)

:Nicolas do you think you can identify the priority/severity for this?

Flags: needinfo?(nchevobbe)
Severity: -- → S3
Flags: needinfo?(nchevobbe)
Priority: -- → P2
Assignee: nobody → hmanilla
Status: NEW → ASSIGNED
Pushed by hmanilla@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a42db02e53a4
[devtools] Avoid showing preview tooltips when hovering over inline previews r=devtools-reviewers,nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch

Comment on attachment 9356595 [details]
Bug 1855685 - [devtools] Avoid showing preview tooltips when hovering over inline previews r=#devtools-reviewers

Beta/Release Uplift Approval Request

  • User impact if declined: Weird UI issue when hovering element in the Debugger editor
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): small devtools change, covered by test
  • String changes made/needed:
  • Is Android affected?: No
Attachment #9356595 - Flags: approval-mozilla-beta?

Comment on attachment 9356595 [details]
Bug 1855685 - [devtools] Avoid showing preview tooltips when hovering over inline previews r=#devtools-reviewers

Approved for 119.0 RC1

Attachment #9356595 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: