Closed Bug 18559 Opened 20 years ago Closed 20 years ago

HR and floater problems

Categories

(Core :: Layout, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: dbaron, Assigned: buster)

References

()

Details

DESCRIPTION:  HRs and floaters don't mix well.

STEPS TO REPRODUCE:
 * load http://www.fas.harvard.edu/~dbaron/css/test/linebox1

ACTUAL RESULTS:
 * HR near the bottom of the page is centered, and goes halfway across the
floater

EXPECTED RESULTS:
 * it shouldn't go over the floater - it should be the same size, but against
the right edge

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-11-11-08-M12

ADDITIONAL INFORMATION:
See historical bug 4615 and bug 4286.
Could float-edge help this?
Assignee: troy → kipp
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 18754 ***
Status: RESOLVED → VERIFIED
Agreed. Marking as verified duplicate of 18754.
re-opening because it's not really a dup, it's a related but slightly different 
issue.  the other bug is about quirks-mode layout.  the test case in this bug is 
in strict mode
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → INVALID
marking invalid.  HR's are block elements, and in strict mode they get laid out 
just like any other block.

let me know if you think we should do otherwise in strict mode, which would mean 
treating HR's as blocks in most cases, but as inlines if they are impacted by 
floaters.  I don't think the CSS spec wants to get into a situation where it 
forces style changes based on geometry.
That leaves the open issues in bug 38370.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.