"Search->Find on this page" doesn't work in View-Source mode

VERIFIED DUPLICATE of bug 6544

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 6544
19 years ago
17 years ago

People

(Reporter: Bill Law, Assigned: kinmoz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Open a view-source window and try Search->Find on this page.  An assertion is
thrown in nsTestServices because the document appears to have more than one
<BODY> element.  I presume that it just fails to work in a release build
(rather than throwing me into the debugger).

It could be that the parser code that generates the html for view-source is
generating extra body elements, but I don't know.  Something funky is going on
but it's probably best to investigate from the text-services point of view.

Comment 1

19 years ago
using the 1999111108 build on win95 -- I do not get an assert. Sujay, can you
try this on an NT using todays build?

Comment 2

18 years ago
Beth and Kathy,got your request to verify this one and try it out on
today's builds...I'm waiting for a working build...I'm on top of it..

Comment 3

18 years ago
I tried this out on both 98 and NT latest build...I don't get an assertion.
(Reporter)

Comment 4

18 years ago
It will only assert in debug builds, perhaps (I'm not sure exactly which form of
assert macro is being used).

Updated

18 years ago
Assignee: beppe → sfraser
Target Milestone: M14

Comment 5

18 years ago
setting to M14 -- assigning to Simon

Comment 6

18 years ago
cc kin

Updated

18 years ago
Assignee: sfraser → kin

Comment 7

18 years ago
You want this for now, kin?
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

18 years ago
Accepting bug.

Updated

18 years ago
Summary: "Search->Find on this page" doesn't work in view-source mode → "Search->Find on this page" doesn't work in View-Source mode

Comment 9

18 years ago
True of the MICROSOFT WINDOWS 98 1999122708 build - the Find function is
inoperative, but causes *no* crash. Why is this report assigned to the Editor?
(Assignee)

Comment 10

18 years ago
It's assigned to the editor because the browser find functionality uses the
editor's nsITextServices interfaces for searching.
(Assignee)

Comment 11

18 years ago

*** This bug has been marked as a duplicate of 6544 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
verified in 1/24 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.