Closed Bug 1858461 Opened 2 months ago Closed 2 months ago

Global search popup doesn't always close when focus is lost

Categories

(Thunderbird :: Toolbars and Tabs, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115 fixed, thunderbird119 fixed, thunderbird120 fixed)

VERIFIED FIXED
120 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 --- fixed
thunderbird119 --- fixed
thunderbird120 --- fixed

People

(Reporter: freaktechnik, Assigned: freaktechnik)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  • Type in the global search
  • Use for example Ctrl+Shift+K to jump somewhere else

Expected result:
Global search suggestions popup closes

Actual result:
Popup stays open

Target Milestone: --- → 120 Branch
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

v.fixed on nightly

Comment on attachment 9357894 [details]
Bug 1858461 - Ensure global search popup is closed on blur. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9357894 - Flags: approval-comm-beta+

good for 115?

Flags: needinfo?(martin)

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Popup sometimes stays open, potentially covering up where the focus moved to.
Testing completed (on c-c, etc.): Tested on comm-beta (121.0b4)
Risk to taking this patch (and alternatives if risky): Low risk

Flags: needinfo?(martin)
Attachment #9367231 - Flags: approval-comm-esr115?

Comment on attachment 9367231 [details] [diff] [review]
bug1858461esr115.patch

[Triage Comment]
Approved for esr115

Attachment #9367231 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.