file:// folders unsortable in personal toolbar

RESOLVED DUPLICATE of bug 139396

Status

RESOLVED DUPLICATE of bug 139396
16 years ago
14 years ago

People

(Reporter: bwucke+bug, Assigned: bugs)

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Steps to reproduce:
1. Enter file:/// in location field.
2. Drag bookmark icon to personal toolbar folder
3. Open the new folder by clicking on it.

Expected results: The files and subdirectories in / appear in alphabetical
order, files on bottom.

Actual results: The files and subdirectories appear in no apparent order, except
files at bottom.

That's not a big problem with small directories, but if I want to access a new
html file I've just saved in some cluttered folder, finding it in the unsorted
pull-down menu takes ages, and since contents of the directory are generated
dynamically and don't appear in any other view, I can't sort them elsewhere
(besides, great fun, manually sorting all directories on the harddisk...)

Please someone check other OS and eventually change OS field accordingly?

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 139396 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Let me rephrase the summary: file:// folders unsortable in personal toolbar

Contents of file:// folders can't be sorted even manually, by dragging them up
or down. (drag doesn't work) I'm fully aware such a feature wouldn't make much
sense as position of every (often very volatile) file would have to be
remembered. Since contents of the directories file:// links point do NOT appear
inside bookmarks.html there is no obvious way how to remember different sort
methods for their subdirectories, but "alphabetical" should be left as the
sensible default, as their contents aren't fully user-controllable unlike common
bookmark folders which are left in initial (dis)order or how the user placed them.

Mark as "depends on" instead?
Summary: file:// folders unsorted in personal toolbar → file:// folders unsortable in personal toolbar
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.