Closed Bug 1863403 Opened 7 months ago Closed 3 months ago

Cards View: consider styling of Group by Sort headers

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 120

Tracking

(Not tracked)

RESOLVED FIXED
126 Branch

People

(Reporter: elijmitchell, Assigned: micah)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: design-needed, regression)

Attachments

(2 files, 2 obsolete files)

Consider Group by Sort styling and improve styling where possible.

At a minimum, make the (#/#) more understandable.

Though for technical reasons we cannot change having 3 rows, we can make the headers look better overall.

+++ This bug was initially created as a clone of Bug #1861853 +++

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/119.0

Steps to reproduce:

Enable card view and group by sort in the message view.

Actual results:

Group headers have the same height as messages (which was recently increased to three lines).

Expected results:

Group headers should be reduced to a single line to reflect the fact that they only contain a signle line of text.

This does not affect touch navigation because the only clickable element in the group header is the arrow button.

No longer depends on: 1861853
See Also: → 1861853
Blocks: 1861062
No longer blocks: 1860631
Depends on: 1858578
Keywords: design-needed
See Also: 1858578
Assignee: elizabeth → nobody
Status: ASSIGNED → NEW
See Also: → 1870705

We need to consider design on this first before implementation.

I'll take a look at the work in progress patch to see where this left off. Update: I've updated the patch with an image.

Assignee: nobody → elizabeth
Assignee: elizabeth → nobody
Assignee: nobody → micah

It looks like the dummy rows generated for the Group by Sort headers are done in the c++. If possible it would be nice to pass this off to js and use a template for easier styling and structure edits.

Flags: needinfo?(geoff)
Attachment #9381814 - Attachment is obsolete: true

I thought we'd got somewhere on this, sorry if I've been the one holding it up.

You can get the unread and total counts by adding unreadCol to this list, totalCol is already there. The values turn up as cellTexts here and propertiesSet will contain "dummy" if you need to detect dummy rows in the JS.

If you're displaying the counts differently you can trash the block from nsMsgGroupView::CellTextForColumn that adds the values to the subject line in brackets.

On a related note, the "replies" icon briefly shows up next to the twisty in these headers, then disappears. That probably should be fixed.

Flags: needinfo?(geoff)
Status: NEW → ASSIGNED
Target Milestone: --- → 126 Branch

Pushed by micah@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/f985a698d474
[Cards View] Style Group by Sort headers. r=vineet

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #9392655 - Attachment description: Bug 1863403: follow up to fix test. r=#thunderbird-front-end-reviewers → Bug 1863403: follow up to fix browser_columns.js test not knowing about unreadCol. r=#thunderbird-front-end-reviewers

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e8508aeba95d
follow up to fix browser_columns.js test not knowing about unreadCol. r=vineet

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED

This sometimes triggers the warning [fluent-dom] An element named "threadpane-sort-header-unread-count" wasn't found in the source. - I think when we previously showed a string that didn't use that element? I only noticed this after running TB, so I'm not sure if it has actual visual impact - but I fear it might.

Attachment #9369282 - Attachment is obsolete: true
Regressions: 1888838
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: