Closed Bug 1864038 Opened 6 months ago Closed 2 months ago

Add keyboard shortcuts for screenshots when a region is selected

Categories

(Firefox :: Screenshots, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
126 Branch
Tracking Status
firefox126 --- verified

People

(Reporter: niklas, Assigned: niklas, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

ctrl + c should copy the selected region and we're thinking ctrl + s should download the selected region

Assignee: nobody → nbaumgardner
Attachment #9364030 - Attachment description: WIP: Bug 1864038 - Add keyboard shortcuts for screenshots overlay. r=sfoster → Bug 1864038 - Add keyboard shortcuts for screenshots overlay. r=sfoster
Status: NEW → ASSIGNED
Severity: -- → N/A
Priority: -- → P2
Attachment #9364030 - Attachment description: Bug 1864038 - Add keyboard shortcuts for screenshots overlay. r=sfoster → WIP: Bug 1864038 - Add keyboard shortcuts for screenshots overlay. r=sfoster
Attachment #9364030 - Attachment description: WIP: Bug 1864038 - Add keyboard shortcuts for screenshots overlay. r=sfoster → Bug 1864038 - Add keyboard shortcuts for screenshots overlay. r=sfoster
Duplicate of this bug: 1888362
Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4bcd94d558a6
Add keyboard shortcuts for screenshots overlay. r=sfoster,fluent-reviewers,bolsson,desktop-theme-reviewers
Flags: needinfo?(nbaumgardner)
Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/13111643fbf4
Add keyboard shortcuts for screenshots overlay. r=sfoster,fluent-reviewers,bolsson,desktop-theme-reviewers

Backed out for causing bc failures on browser_screenshots_drag_scroll_test.js

Backout link

Push with failures

Failure log

Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d41d18cecc78
Add keyboard shortcuts for screenshots overlay. r=sfoster,fluent-reviewers,bolsson,desktop-theme-reviewers

Backed out for causing bc failures in browser_screenshots_drag_scroll_test.js

  • Backout link
  • Push with failures
  • Failure Log
  • Failure line: TEST-UNEXPECTED-FAIL | browser/components/screenshots/tests/browser/browser_screenshots_drag_scroll_test.js | Uncaught exception in test bound test_scrollIfByEdge - Waiting for window to scroll to 990, 990 - timed out after 50 tries.
Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/74ade7d0f955
Add keyboard shortcuts for screenshots overlay. r=sfoster,fluent-reviewers,bolsson,desktop-theme-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 126 Branch
Duplicate of this bug: 1787658

Verified as fixed using the latest Nightly 127.0a1 and Firefox 126.0b5 (while screenshots.browser.component.enabled is set to true in about:config) on macOS 13, Ubuntu 22.04 and Windows 10 x64 - both key shortcuts Ctrl/Cmd + C and Ctrl/Cmd + S can be properly used to copy and download a screenshot region.

Status: RESOLVED → VERIFIED
Regressions: 1893879
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: