Closed Bug 1864124 Opened 6 months ago Closed 6 months ago

Advanced address book search throws if condition is empty

Categories

(Thunderbird :: Address Book, defect)

defect

Tracking

(thunderbird_esr115 fixed, thunderbird120 affected)

RESOLVED FIXED
121 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird120 --- affected

People

(Reporter: mkmelin, Assigned: mkmelin)

Details

Attachments

(1 file)

In address book, Edit | Find | Search addresses. Leave display name empty, hit search.

Uncaught NS_ERROR_ILLEGAL_VALUE: Failed to create condition string from name=DisplayName, condition=c, value=, cond=2
createBooleanConditionString resource:///modules/QueryStringToExpression.jsm:167
convert resource:///modules/QueryStringToExpression.jsm:55
search resource:///modules/LDAPDirectory.jsm:187
ABView chrome://messenger/content/addressbook/abView.js:23
SetAbView chrome://messenger/content/addressbook/abResultsPane.js:73
onSearch chrome://messenger/content/addressbook/abSearchDialog.js:333
onSearchButton chrome://messenger/content/addressbook/abSearchDialog.js:342
oncommand chrome://messenger/content/addressbook/abSearchDialog.xhtml:1
QueryStringToExpression.jsm:167

Don't throw, show the address book listing without limitation instead.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e4b2a40488f4
Handle advanced address book search with empty name. r=john.bieling

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 121 Branch

Comment on attachment 9362972 [details]
Bug 1864124 - Handle advanced address book search with empty name. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: searching address without criteria doesn't end well
Testing completed (on c-c, etc.): c-c, beta
Risk to taking this patch (and alternatives if risky): safe. We can also wontfix as it's not a huge issue.

Attachment #9362972 - Flags: approval-comm-esr115?

Comment on attachment 9362972 [details]
Bug 1864124 - Handle advanced address book search with empty name. r=#thunderbird-reviewers

[Triage Comment]
approved for esr115

Attachment #9362972 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: