Closed Bug 1864356 Opened 3 months ago Closed 3 months ago

Update PDF.js to new version 78841199750f50cd94033850bdd53910a11133b9 from 2023-11-12 13:04:02

Categories

(Firefox :: PDF Viewer, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
121 Branch
Tracking Status
firefox121 --- fixed

People

(Reporter: update-bot, Assigned: calixte)

References

(Blocks 1 open bug)

Details

(Whiteboard: [3pl-filed][task_id: PX-rrl3pRCm4_6sD8pd8PA])

Attachments

(1 file)

This update covers 18 commits. Here are the overall diff statistics, and then the commit information.


toolkit/components/pdfjs/content/build/pdf.mjs | 107 ++++++-
toolkit/components/pdfjs/content/build/pdf.scripting.mjs | 4 +-
toolkit/components/pdfjs/content/build/pdf.worker.mjs | 61 ++-
toolkit/components/pdfjs/content/web/images/editor-toolbar-delete.svg | 5 +
toolkit/components/pdfjs/content/web/viewer-geckoview.mjs | 7 +-
toolkit/components/pdfjs/content/web/viewer.css | 156 +++++++++-
toolkit/components/pdfjs/content/web/viewer.html | 1 -
toolkit/components/pdfjs/content/web/viewer.mjs | 8 +-
toolkit/components/pdfjs/moz.yaml | 4 +-
9 files changed, 301 insertions(+), 52 deletions(-)


5687326046c6eede62578c4891ced5074364ff65 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/5687326046c6eede62578c4891ced5074364ff65
Authored: 2023-11-12 13:41:10 +0100
Committed: 2023-11-12 13:48:02 +0100

Clean-up the CI workflow a bit

After recent PRs the size and scope of the CI workflow is now reduced, and this patch tries to simplify things further. More specifically we can directly specify the gulp-tasks in the workflow, and thus clean-up the gulpfile a tiny bit.

Note that this will technically be slower, since the tests are now run in series (rather than in parallel), however gulp externaltest runs so quickly that it really won't matter in practice.

Files Modified:

  • .github/workflows/ci.yml
  • gulpfile.mjs

d89ca978876e14edb8ebdd5cd30c85af8dcceaea by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/d89ca978876e14edb8ebdd5cd30c85af8dcceaea
Authored: 2023-11-12 09:51:37 +0100
Committed: 2023-11-12 13:27:29 +0100

Move gulp typestest to a separate GitHub Actions workflow

This way we introduce more parallelism in the GitHub Actions tests, which should reduce overall runtime and thus cannot hurt.

Files Added:

  • .github/workflows/types_tests.yml

Files Modified:

  • gulpfile.mjs

2f70369d023275beba87617a55c825b7d6fa60f3 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/2f70369d023275beba87617a55c825b7d6fa60f3
Authored: 2023-11-12 10:09:39 +0100
Committed: 2023-11-12 10:21:29 +0100

Move linting to a separate GitHub Actions workflow

This way we introduce more parallelism in the GitHub Actions tests, which should reduce overall runtime and thus cannot hurt.

Files Added:

  • .github/workflows/lint.yml

Files Modified:

  • gulpfile.mjs

ade692ff2e1fe86e635c9fe571afe3f5ee1a1d44 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/ade692ff2e1fe86e635c9fe571afe3f5ee1a1d44
Authored: 2023-11-12 09:22:59 +0100
Committed: 2023-11-12 09:30:26 +0100

Set a type for the Blob used in createCDNWrapper (issue 17259)

Hopefully this is enough to address the problem of initializing the Worker in Chromium-based browsers.
Locally I've tried to force use of createCDNWrapper in development mode, by commenting out the isSameOrigin checks, and worker-loading fails against master and works with this patch.

Files Modified:

  • src/display/api.js

61ed77cfb4baf530c2814066ab2c9cbdd42e4328 by Takashi Tamura

https://github.com/mozilla/pdf.js/commit/61ed77cfb4baf530c2814066ab2c9cbdd42e4328
Authored: 2023-11-10 17:27:04 +0900
Committed: 2023-11-12 07:30:36 +0900

Rename *.d.ts to *.d.mts. Close #17241

Add a type test for legacy.

Files Added:

  • external/dist/legacy/web/pdf_viewer.d.mts
  • external/dist/web/pdf_viewer.d.mts
  • test/types/legacy.ts
  • test/types/package.json

Files Deleted:

  • external/dist/legacy/web/pdf_viewer.d.ts
  • external/dist/web/pdf_viewer.d.ts

Files Modified:

  • gulpfile.mjs
  • test/types/tsconfig.json

Files Changed:

  • R100 external/dist/legacy/build/pdf.d.ts
  • R090 test/types/main.ts

2d42c0454346d4a7371a3e78678f0ed836104566 by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/2d42c0454346d4a7371a3e78678f0ed836104566
Authored: 2023-11-11 20:47:05 +0100
Committed: 2023-11-11 20:47:05 +0100

[Editor] Avoid to click on the delete button in the freetext integration tests

Files Modified:

  • test/integration/freetext_editor_spec.mjs

4b7a0d1841a983e37a10d4fcb0fa82d026ff6000 by Tim van der Meij

https://github.com/mozilla/pdf.js/commit/4b7a0d1841a983e37a10d4fcb0fa82d026ff6000
Authored: 2023-11-11 15:58:30 +0100
Committed: 2023-11-11 15:58:30 +0100

Update translations to the most recent versions

Files Modified:

  • l10n/da/viewer.ftl
  • l10n/fr/viewer.ftl
  • l10n/pt-PT/viewer.ftl
  • l10n/rm/viewer.ftl
  • l10n/sl/viewer.ftl
  • l10n/zh-CN/viewer.ftl

8e2c9a30d79f4f48d31edb05b4ead492c1d4d50e by Tim van der Meij

https://github.com/mozilla/pdf.js/commit/8e2c9a30d79f4f48d31edb05b4ead492c1d4d50e
Authored: 2023-11-11 15:57:28 +0100
Committed: 2023-11-11 15:57:28 +0100

Update dependencies to the most recent versions

Files Modified:

  • package-lock.json
  • package.json

e61b8327645170643556b6b189ef7f34cb1a404c by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/e61b8327645170643556b6b189ef7f34cb1a404c
Authored: 2023-11-10 18:19:39 +0100
Committed: 2023-11-10 18:19:39 +0100

Tweak the background-color of the editorParamsToolbars

Currently the background-color of the editorParamsToolbars don't match that of the arrow, which is especially noticable in dark mode (see zoomed-in screen-shots below).
The simplest solution seem to be to just style the editorParamsToolbars like the secondaryToolbar, to limit the amount of CSS changes required.

Files Modified:

  • web/viewer.css

334f0eb06050884cdde9abd09a2d769da0bf5f47 by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/334f0eb06050884cdde9abd09a2d769da0bf5f47
Authored: 2023-11-08 18:13:15 +0100
Committed: 2023-11-10 15:19:43 +0100

[Editor] Add a toolbar to selected editors with a button to delete it (bug 1863763)

Files Added:

  • src/display/editor/toolbar.js
  • web/images/editor-toolbar-delete.svg

Files Modified:

  • gulpfile.mjs
  • src/display/editor/editor.js
  • src/display/editor/ink.js
  • src/display/editor/tools.js
  • test/integration/freetext_editor_spec.mjs
  • web/annotation_editor_layer_builder.css

59ce1a4a3fdac2a59b32e615ce68fb2ef310946f by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/59ce1a4a3fdac2a59b32e615ce68fb2ef310946f
Authored: 2023-11-10 11:48:44 +0100
Committed: 2023-11-10 14:16:20 +0100

Fix the maxp table version in font to make it visible on Windows

Files Added:

  • test/pdfs/issue16839.pdf.link

Files Modified:

  • src/core/fonts.js
  • test/test_manifest.json

823d375b8b979680a0932f3e199a76fbdb453ac8 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/823d375b8b979680a0932f3e199a76fbdb453ac8
Authored: 2023-11-10 12:49:37 +0100
Committed: 2023-11-10 13:22:49 +0100

Ensure that the viewer waits for the library to complete loading (issue 17228)

This should hopefully fix 17228, by tweaking the build scripts to give the GENERIC viewer something to await to avoid breaking third-party users of the standalone viewer components.

Files Modified:

  • gulpfile.mjs
  • web/pdfjs.js

ec396c215025e17e777e77711aed4b64313fc566 by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/ec396c215025e17e777e77711aed4b64313fc566
Authored: 2023-11-09 13:50:33 +0100
Committed: 2023-11-09 13:50:33 +0100

Don't avoid to execute the Blur callback when blurring a text field (bug 1863910)

Files Added:

Files Modified:

  • src/display/annotation_layer.js
  • test/integration/scripting_spec.mjs
  • test/pdfs/.gitignore

bf016743fc9fcf6da3df5c9ab85ecbfd028a17c3 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/bf016743fc9fcf6da3df5c9ab85ecbfd028a17c3
Authored: 2023-11-09 07:55:48 +0100
Committed: 2023-11-09 08:08:17 +0100

Remove the "Open file"-button from the main toolbar

This button is only used in the GENERIC viewer, and will currently be visible either in the main or secondary toolbars (depending on the viewer width).
To simplify upcoming changes, and to avoid then having to complicate the relevant CSS rules unnecessarily, let's place the "Open file"-button permanently in the secondary toolbar instead.

(Note that the GENERIC viewer also, since five years, supports drag-and-drop in order to open local files.)

Files Modified:

  • web/toolbar.js
  • web/viewer.css
  • web/viewer.html
  • web/viewer.js

ff62fc8e2c7b805f5ce6ee36828b08cf85cb277a by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/ff62fc8e2c7b805f5ce6ee36828b08cf85cb277a
Authored: 2023-11-08 10:52:56 +0100
Committed: 2023-11-08 14:39:13 +0100

Skip fieldObjects that are not actually References

The fieldObjects-getter is implemented in the PDFDocument class, which means that the this._localIdFactory-property that we pass to AnnotationFactory.create doesn't actually exist.
The reason that this hasn't caused any bugs, that I'm aware of, is that all /Fields-entries need to be References to actually make sense.

Files Modified:

  • src/core/document.js

65c827b0ebf566631f49dc602681e326513982c7 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/65c827b0ebf566631f49dc602681e326513982c7
Authored: 2023-11-08 09:51:52 +0100
Committed: 2023-11-08 14:38:57 +0100

Ensure that fieldObjects and #collectFieldObjects handles References correctly

The fieldObjects-getter itself is called, from src/core/worker.js, in a way that'll ensure that any MissingDataExceptions are handled. However the problem is that the actual data-lookups in fieldObjects and #collectFieldObjects are done inside of a Promise, which means that MissingDataExceptions won't be handled and parsing could thus break.

To address this we change all data-lookups to be asynchronous instead.

Files Modified:

  • src/core/document.js

acc62f80de3a3df966275908d64b48aa5ab0e0bb by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/acc62f80de3a3df966275908d64b48aa5ab0e0bb
Authored: 2023-11-07 15:31:43 +0100
Committed: 2023-11-07 19:58:29 +0100

Don't try to collect a nonexistent field because of an invalid ref

Files Added:

  • test/pdfs/issue17232.pdf.link

Files Modified:

  • src/core/document.js
  • test/test_manifest.json

f16401bd678bac29ca2560dca0dfbde7be48de39 by Tim van der Meij

https://github.com/mozilla/pdf.js/commit/f16401bd678bac29ca2560dca0dfbde7be48de39
Authored: 2023-11-05 18:50:26 +0100
Committed: 2023-11-05 18:58:09 +0100

Bump the stable version in pdfjs.config

Files Modified:

  • pdfjs.config

Assignee: nobody → update-bot
Status: NEW → ASSIGNED

The try push is done, we found jobs with unclassified failures.

Known Issues (From Push Health):

  • toolkit/components/pdfjs/test/browser_pdfjs_editing_contextmenu.js

    • 2 of 2 failed on different tasks
      - test-linux1804-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (VQ6xCgjjQh6Zq1jxT0c6Gg)
      - test-linux1804-64-qr/debug-mochitest-browser-chrome-swr-1 (XwO7bNGDQH2PhrgQ5wcGvQ)
  • toolkit/components/pdfjs/test/browser_pdfjs_editing_telemetry.js

    • 2 of 2 failed on different tasks
      - test-linux1804-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (VQ6xCgjjQh6Zq1jxT0c6Gg)
      - test-linux1804-64-qr/debug-mochitest-browser-chrome-swr-1 (XwO7bNGDQH2PhrgQ5wcGvQ)

Known Issues (From Taskcluster):

  • test-windows11-64-2009-qr/opt-mochitest-browser-chrome-1 (XNNuFhh9TziXevreFNHzAQ) - new failure not classified
  • test-macosx1015-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (d8rfxqcyRfCnv2K_thIhjg) - new failure not classified
  • test-windows11-64-2009-qr/debug-mochitest-browser-chrome-spi-nw-1 (NKfCawXYSjSGIIzYElajxQ) - new failure not classified
  • test-windows11-64-2009-qr/debug-mochitest-browser-chrome-1 (SZLVWPYqTW6yIDsiGsJZxw) - new failure not classified
  • test-windows11-64-2009-qr/debug-mochitest-browser-chrome-msix-1 (OmpUPUobR5-YHsOWS-6cGg) - new failure not classified
  • test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-1 (HXGxwR1GSGKlEQI6TKM7Ww) - new failure not classified
  • test-windows11-64-2009-qr/opt-mochitest-browser-chrome-msix-1 (cDNo4RHPRDWnXJqp9onNSA) - new failure not classified
  • test-windows11-64-2009-qr/debug-mochitest-browser-chrome-swr-1 (c0G85WzWSgGQqIvVzFcfbA) - new failure not classified
  • test-macosx1015-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (NXOVtf-ZQtOeQTj6eoWkZQ) - new failure not classified
  • test-macosx1015-64-qr/opt-mochitest-browser-chrome-1 (AE4y1JhxTYajbzZwvmLiAw) - new failure not classified
  • test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-1 (NL91RDSxR3C40OaGNZGY3A) - new failure not classified
  • test-windows11-32-2009-qr/debug-mochitest-browser-chrome-1 (bKk5YH9NR6ilz8ULM1eIqA) - new failure not classified
  • test-linux1804-64-qr/debug-mochitest-browser-chrome-swr-1 (XwO7bNGDQH2PhrgQ5wcGvQ) - new failure not classified
  • test-linux1804-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (VQ6xCgjjQh6Zq1jxT0c6Gg) - new failure not classified
  • test-macosx1015-64-qr/debug-mochitest-browser-chrome-1 (MgoMXAECRuWYD_9xDR2C4A) - new failure not classified
  • test-linux1804-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (McGlOG7ZTnKUzmLp7WtTfA) - new failure not classified
  • test-windows11-64-2009-qr/opt-mochitest-browser-chrome-spi-nw-1 (EfZwpPTrTZSKhiUUsQYhrA) - new failure not classified
  • test-windows11-32-2009-qr/opt-mochitest-browser-chrome-1 (TEklBS9nTdm0Qob_BFFvag) - new failure not classified

Needs Investigation (From Push Health):

  • toolkit/components/pdfjs/test/browser.toml

    • 18 of 18 failed on different tasks
      - test-linux1804-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (VQ6xCgjjQh6Zq1jxT0c6Gg)
      - test-linux1804-64-qr/debug-mochitest-browser-chrome-swr-1 (XwO7bNGDQH2PhrgQ5wcGvQ)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-1 (HXGxwR1GSGKlEQI6TKM7Ww)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (McGlOG7ZTnKUzmLp7WtTfA)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-1 (NL91RDSxR3C40OaGNZGY3A)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-spi-nw-1 (EfZwpPTrTZSKhiUUsQYhrA)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-1 (XNNuFhh9TziXevreFNHzAQ)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-msix-1 (cDNo4RHPRDWnXJqp9onNSA)
      - test-windows11-32-2009-qr/debug-mochitest-browser-chrome-1 (bKk5YH9NR6ilz8ULM1eIqA)
      - test-windows11-32-2009-qr/opt-mochitest-browser-chrome-1 (TEklBS9nTdm0Qob_BFFvag)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-swr-1 (c0G85WzWSgGQqIvVzFcfbA)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-spi-nw-1 (NKfCawXYSjSGIIzYElajxQ)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-1 (SZLVWPYqTW6yIDsiGsJZxw)
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-1 (MgoMXAECRuWYD_9xDR2C4A)
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (NXOVtf-ZQtOeQTj6eoWkZQ)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-1 (AE4y1JhxTYajbzZwvmLiAw)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (d8rfxqcyRfCnv2K_thIhjg)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-msix-1 (OmpUPUobR5-YHsOWS-6cGg)
  • toolkit/components/pdfjs/test/browser_pdfjs_editing_contextmenu.js

    • 16 of 16 failed on different tasks
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-1 (HXGxwR1GSGKlEQI6TKM7Ww)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (McGlOG7ZTnKUzmLp7WtTfA)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-1 (NL91RDSxR3C40OaGNZGY3A)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-spi-nw-1 (EfZwpPTrTZSKhiUUsQYhrA)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-1 (XNNuFhh9TziXevreFNHzAQ)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-msix-1 (cDNo4RHPRDWnXJqp9onNSA)
      - test-windows11-32-2009-qr/debug-mochitest-browser-chrome-1 (bKk5YH9NR6ilz8ULM1eIqA)
      - test-windows11-32-2009-qr/opt-mochitest-browser-chrome-1 (TEklBS9nTdm0Qob_BFFvag)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-swr-1 (c0G85WzWSgGQqIvVzFcfbA)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-spi-nw-1 (NKfCawXYSjSGIIzYElajxQ)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-1 (SZLVWPYqTW6yIDsiGsJZxw)
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-1 (MgoMXAECRuWYD_9xDR2C4A)
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (NXOVtf-ZQtOeQTj6eoWkZQ)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-1 (AE4y1JhxTYajbzZwvmLiAw)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (d8rfxqcyRfCnv2K_thIhjg)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-msix-1 (OmpUPUobR5-YHsOWS-6cGg)
  • toolkit/components/pdfjs/test/browser_pdfjs_editing_telemetry.js

    • 16 of 16 failed on different tasks
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-1 (HXGxwR1GSGKlEQI6TKM7Ww)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (McGlOG7ZTnKUzmLp7WtTfA)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-1 (NL91RDSxR3C40OaGNZGY3A)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-spi-nw-1 (EfZwpPTrTZSKhiUUsQYhrA)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-1 (XNNuFhh9TziXevreFNHzAQ)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-msix-1 (cDNo4RHPRDWnXJqp9onNSA)
      - test-windows11-32-2009-qr/debug-mochitest-browser-chrome-1 (bKk5YH9NR6ilz8ULM1eIqA)
      - test-windows11-32-2009-qr/opt-mochitest-browser-chrome-1 (TEklBS9nTdm0Qob_BFFvag)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-swr-1 (c0G85WzWSgGQqIvVzFcfbA)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-spi-nw-1 (NKfCawXYSjSGIIzYElajxQ)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-1 (SZLVWPYqTW6yIDsiGsJZxw)
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-1 (MgoMXAECRuWYD_9xDR2C4A)
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (NXOVtf-ZQtOeQTj6eoWkZQ)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-1 (AE4y1JhxTYajbzZwvmLiAw)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (d8rfxqcyRfCnv2K_thIhjg)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-msix-1 (OmpUPUobR5-YHsOWS-6cGg)
  • toolkit/components/pdfjs/test/browser_pdfjs_stamp_telemetry.js

    • 18 of 18 failed on different tasks
      - test-linux1804-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (VQ6xCgjjQh6Zq1jxT0c6Gg)
      - test-linux1804-64-qr/debug-mochitest-browser-chrome-swr-1 (XwO7bNGDQH2PhrgQ5wcGvQ)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-1 (HXGxwR1GSGKlEQI6TKM7Ww)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (McGlOG7ZTnKUzmLp7WtTfA)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-1 (NL91RDSxR3C40OaGNZGY3A)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-spi-nw-1 (EfZwpPTrTZSKhiUUsQYhrA)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-1 (XNNuFhh9TziXevreFNHzAQ)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-msix-1 (cDNo4RHPRDWnXJqp9onNSA)
      - test-windows11-32-2009-qr/debug-mochitest-browser-chrome-1 (bKk5YH9NR6ilz8ULM1eIqA)
      - test-windows11-32-2009-qr/opt-mochitest-browser-chrome-1 (TEklBS9nTdm0Qob_BFFvag)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-swr-1 (c0G85WzWSgGQqIvVzFcfbA)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-spi-nw-1 (NKfCawXYSjSGIIzYElajxQ)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-1 (SZLVWPYqTW6yIDsiGsJZxw)
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-1 (MgoMXAECRuWYD_9xDR2C4A)
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-spi-nw-1 (NXOVtf-ZQtOeQTj6eoWkZQ)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-1 (AE4y1JhxTYajbzZwvmLiAw)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (d8rfxqcyRfCnv2K_thIhjg)
      - test-windows11-64-2009-qr/debug-mochitest-browser-chrome-msix-1 (OmpUPUobR5-YHsOWS-6cGg)

These failures could mean that the library update changed something and caused
tests to fail. You'll need to review them yourself and decide where to go from here.

In either event, I have done all I can and you will need to take it from here. If you
don't want to land my patch, you can replicate it locally for editing with
./mach vendor toolkit/components/pdfjs/moz.yaml

When reviewing, please note that this is external code, which needs a full and
careful inspection - not a rubberstamp.

Assignee: update-bot → cdenizet
Flags: needinfo?(cdenizet)
Attachment #9363181 - Attachment description: Bug 1864356 - Update PDF.js to 78841199750f50cd94033850bdd53910a11133b9 → Bug 1864356 - Update PDF.js to 78841199750f50cd94033850bdd53910a11133b9 r=#pdfjs-reviewers
Flags: needinfo?(cdenizet)
Pushed by cdenizet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f89142d3759d
Update PDF.js to 78841199750f50cd94033850bdd53910a11133b9 r=pdfjs-reviewers,marco
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 121 Branch
You need to log in before you can comment on or make changes to this bug.