Table width miscalculations with NOWRAP and COLSPAN attributes

VERIFIED FIXED in Future

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: msw, Assigned: karnaze)

Tracking

({css2, testcase})

Trunk
Future
x86
Linux
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(8 attachments)

(Reporter)

Description

19 years ago
When viewing http://www.mozilla.org/unix/dpi.html, resizing the window to 742
pixels on my system causes the table to the left to misfill.  The following
warning message is repeated several times while rendering the page:

WARNING: over allocated: 'totalAllocated <= maxWidth', file
../../../../../layout/html/table/src/BasicTableLayoutStrategy.cpp, line 316

Sizing the window to 741 pixels makes the table render properly.  You may need
to resize to a different width to see the problem.

I'm attaching a screenshot of the misrendered page.
(Reporter)

Comment 1

19 years ago
Created attachment 2805 [details]
Screenshot of table misrender
(Reporter)

Comment 2

19 years ago
The misrendering happens on http://www.mozilla.org/ as well, but the browser
window must be much wider (~1800 pixels).

Comment 3

19 years ago
This is wacky. The rows in the table containing the menu have gigantic colspans,
much bigger than the width of the table. This is apparently a kludge to
workaround some problem that doesn't seem to exist any more. I'll fix the web
site.

I suppose this counts as a quirks mode bug since this doesn't happen with 4.6.

_______________________
|      COLSPAN = 20    |
------------------------
|         |            |
| <empty> | COLSPAN=19 |
|         |            |
------------------------

Comment 4

19 years ago
Created attachment 2828 [details]
test case where colspan is greater than the number of columns

Comment 5

19 years ago
Created attachment 2837 [details]
shows the test case where an embedded table overflows the table that's supposed to contain it.

Comment 6

19 years ago
The test case I added shows that this happens when the colspan on <TD> tags is
set to a number greater than the number of available columns.

The TD containing "At A Glance" has no columns after it so it can have at most,
colspan=1. if its colspan is set to 2 or more and the colspan of the row above
is set to more than the span of "At a Glance" then this problem occurs.

If the window is resized then the table collapses and displays the way it was
intended.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
(Reporter)

Comment 7

19 years ago
Created attachment 3743 [details]
Simple test case for this bug.
(Reporter)

Comment 8

19 years ago
Created attachment 3744 [details]
screenshot of a misrender of this bug
(Reporter)

Comment 9

19 years ago
From my testcase:

This page has two tables on it.  The outer table's border will be
smaller on the right than the inner table's boarder when the browser is
at certain sizes.  The browser must be wide enought to not wrap the
text in table 2 R2 C1, and the width of the browser must be less than
the width of the inner table.

This behavior is NOT exhibited if Table 2 R1 C2 does not have the
NOWRAP attribute.

The browser needs to wrap Table 2 R2 C1 to allow Table 2 R1 C2 to fit onto the
screen.  It's almost as though R1 C2's space requirement isn't taken into
account when calculating when to wrap R2 C1.
(Reporter)

Updated

19 years ago
Whiteboard: [TESTCASE]
(Reporter)

Comment 10

19 years ago
Created attachment 3748 [details]
More complex testcase that shows even proper table html exhibits the problem
(Reporter)

Comment 11

19 years ago
Created attachment 3749 [details]
Screenshot of above testcase misrendered
(Reporter)

Comment 12

19 years ago
Notice, also the horizontal scrollbar is missing when the inner table's bounds
extend past the area viewable by the browser.
(Reporter)

Updated

19 years ago
Summary: http://www.mozilla.org/unix/dpi.html table rendering problems → Table width miscalculations with NOWRAP and COLSPAN attributes
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase

Updated

19 years ago
Whiteboard: [TESTCASE]
(Assignee)

Comment 14

19 years ago
Moving to M15.
Target Milestone: M14 → M15
Blocks: 7954
Keywords: css2
COLSPAN is not technically part of CSS2, and rendering not part of HTML4, but
this problem is related to support for both, so adding relevant markers.
(Assignee)

Comment 16

19 years ago
mass move to m16
Target Milestone: M15 → M16

Comment 17

19 years ago
Created attachment 7697 [details]
Simple test case using <IMG> instead of NOWRAP

Comment 18

19 years ago
Discovered a similar bug using <IMG> <a
href="http://bugzilla.mozilla.org/showattachment.cgi?attach_id=7697">
(id=7697)</a>
(I hope this works, mozilla is doing strange things in this text box...)
(Assignee)

Comment 19

19 years ago
Moving to M18.
Target Milestone: M16 → M18
(Assignee)

Comment 20

19 years ago
This bug has been marked "future" because we have determined that it is not 
critical for netscape 6.0. If you feel this is an error, or if it blocks your 
work in some way -- please attach your concern to the bug for reconsideration.
Target Milestone: M18 → Future

Comment 21

19 years ago
I would though consider this rather important, since this bug seems to affect
more pages than you expected...I have an example on one which absolutely loses
its design and everything. ;(

Please check if http://www.netstream.ch and its subpages (main seems to work
fine) fall into this bug.

Comment 22

18 years ago
Well I see this not happening anymore (i.e. can't reproduce with the testcases
anymore), it might have been fixed in conjunction with another bug...dare to
mark/verify this fixed? Reporter? Owner? Anyone?

Comment 23

18 years ago
I tested on Linux and compared with an old build. It looks like it got fixed
somehow.  Very nice!

Comment 24

18 years ago
bug 14929 colspan cell's should honour percentage width's
was fixed in september
marking as fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 25

18 years ago
Tested on Win, Mac and Linux with 11/21 trunk builds. Verifying fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.