Closed Bug 186594 Opened 18 years ago Closed 18 years ago

Reference to ::db_sock is used in globals.pl without exporting this parameter in Config.pm

Categories

(Bugzilla :: Bugzilla-General, defect)

2.17.2
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: sergey, Assigned: sergey)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021209
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021209

Config.pm is not exporting $::db_sock (a new parameter in localconfig) which is
used elsewhere

Reproducible: Always

Steps to Reproduce:
1. Upgrade to 2.17.2 (based on CVS tag) from 2.17 (passing 2.17.1)
2. Use normally
Actual Results:  
Error in error log of Apache: "Use of uninitialized value in string ne at
globals.pl line 126."

Expected Results:  
Export db_sock

Index: Bugzilla/Config.pm
===================================================================
RCS file: /prj/proboard/cvshome/bugzilla/Bugzilla/Config.pm,v
retrieving revision 1.5
diff -u -r1.5 Config.pm
--- Bugzilla/Config.pm  20 Dec 2002 05:12:45 -0000      1.5
+++ Bugzilla/Config.pm  20 Dec 2002 16:34:41 -0000
@@ -49,7 +49,7 @@
 %Bugzilla::Config::EXPORT_TAGS =
   (
    admin => [qw(GetParamList UpdateParams SetParam WriteParams ReplaceScriptName)],
-   db => [qw($db_host $db_port $db_name $db_user $db_pass)],
+   db => [qw($db_host $db_port $db_name $db_user $db_pass $db_sock)],
   );
 Exporter::export_ok_tags('admin', 'db');
Version: unspecified → 2.17.2
Myk: this would break your replication stuff (which you already have running on
mothra) I would think.  How is this working on mothra?

Sergey, can you upload that patch as an attachment rather than pasting it in the
comments?  That way we can use the status flags and so forth on it.  Thanks!

BTW: who confirmed this bug?  According to the bugmail I got, it was originally
filed as UNCONFIRMED, and it's showing to me as NEW currently.  There's no
record of the status being changed in the bug activity...
I filed bug 186652, http://bugzilla.mozilla.org/show_bug.cgi?id=186652, in
regards to the bug being NEW instead of UNCONFIRMED.
Attached patch Config-db_sock.patch (obsolete) — Splinter Review
The patch adds db_sock to the already present db_host etc.
Comment on attachment 110087 [details] [diff] [review]
Config-db_sock.patch

This looks fine. I'm not in a place where I can check why it currently works,
but $::db_* are globlas, so don't need exporting yet. r=bbaetz
Attachment #110087 - Flags: review?(myk) → review+
reassigning to patch author
Assignee: justdave → sergeyli
Flags: approval+
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18
Attached patch patch unrottedSplinter Review
For the record, here's the patch I applied.  The previously attached one failed
to apply because of the "ReplaceScriptName" tag on the previous line.  Not sure
where that came from. :)
Attachment #110087 - Attachment is obsolete: true
Comment on attachment 110139 [details] [diff] [review]
patch unrotted

carrying forward r=bbaetz
Attachment #110139 - Flags: review+
Checking in Bugzilla/Config.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Config.pm,v  <--  Config.pm
new revision: 1.11; previous revision: 1.10
done
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.