Closed Bug 18680 Opened 22 years ago Closed 17 years ago

[IME 2000] Modifying characters in conversion mode does not work.

Categories

(Core :: Internationalization, defect, P3)

x86
Windows 2000
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: teruko, Assigned: masayuki)

References

Details

(Keywords: intl, platform-parity)

IME 2000 has the following new feature.

In Notepad,
1. Turn on IME and change to Zenkaku Hiragana mode
2. Type keystroke "ochanosayouwooshieru" (at this time, do not hit enter)
3. Hit space bar (the carret is at the end of string)
4. Move the carret 4 characters back by using mouse (you cannot use left
   arrow key there).
5. Use backspace key to delete the character one before the carret
6. Type keystroke "you" and hit space
   Then, the string will be committed.

In Composer, the behavior is following.

After the step #3, the carret is not at the end of string.
In step #5, Backspace key does not delete the character.
   Backspace key will change the last 4 characters to hiragana.

Tested 11-10-17 Win32 M11 build under Windows 2000 Japanese final beta.
Status: NEW → ASSIGNED
Target Milestone: M13
Target Milestone: M13 → M14
I am not sure what we should do w/ reconversion. Move it to M14.
IME 2000 is not in Beta criteria. need help 
Makoto-san: can you take over this bug ?
Whiteboard: [Need Help]
move it to M17
Target Milestone: M14 → M17
Keywords: pp
I could reproduce on Windows 2000 + IME2000.  but I couldn't reproduce on 
Windows NT 4.0 SP3 + IME2000.  So I changed OS platform to Windows 2000.
OS: Windows NT → Windows 2000
How about win 98 ? IS that true the reconversion first introduced in Win98
Sorry, this issue doesn't haver nothing to reconversion.  This is the handing 
of IME.  When I tested on NT4SP6 + WXG2 (made by A.I.Soft), it actions as same 
as teruko's report.
So when WM_LBUTTONDOWN is send, it may be not have to call ResetInputState()...
I cannot repro at notepad etc... on Windows 98 SE + MS-IME98.
This action will repro at notepad, Word 2000 etc on Windows 2000 + IME2000.
I think this issue should be "WONTFIX".
This action depends on IME.  If this should fix, Composer must stop handing of 
IME.
frank, please tell me your suggestion...
Keywords: helpwanted
Summary: [IME 2000][PP] Modifying characters in conversion mode does not work. → [IME 2000] Modifying characters in conversion mode does not work.
Whiteboard: [Need Help]
what do you mean "Composer must stop handing of IME." ?
Yes.
If this bug fix, Composer must write code depended on IME2000 like Word 2000 
and Windows 2000.
what does that mean . does that mean we need to react to some new IMM messages ?
Putting nsbeta2 since this is beta2 criteria.
Keywords: nsbeta2
nsbeta2 ? I don't think we can fix this even by GM. 
Putting on [nsbeta2-] radar. Not critical to beta2.
Whiteboard: [nsbeta2-]
Assignee: ftang → shanjian
Status: ASSIGNED → NEW
reassign to shanjian- we may not have time to implement this for beta2 
Status: NEW → ASSIGNED
probably, you must use WM_MSIME_MOUSE and WM_MSIME_QUERYPOSITION message.
But I have no sample and addtional document.

See the following URL.
http://msdn.microsoft.com/library/specs/MSIMEIF_perimeinterfaces.htm
nsbeta3+ per i18n bug meeting. 
Keywords: nsbeta3
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3+]
I don't think the current IME arch support this kind of editing. We have the 
same problme on Mac. We should consider drop this from Netscape6.
Whiteboard: [nsbeta2-][nsbeta3+] → [nsbeta2-][nsbeta3+] (ftang: consider to cut)
Cut this . Mark it as nsbeta3- and mark future. 
Whiteboard: [nsbeta2-][nsbeta3+] (ftang: consider to cut) → [nsbeta2-][nsbeta3-]
Target Milestone: M17 → Future
reassign to yokoyama
Assignee: shanjian → yokoyama
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Keywords: intl, nsbeta1
Keywords: nsBranch
Blocks: 99171
nsbranch- since Frank moved it to future
Keywords: nsbranchnsbranch-
Blocks: 104166
Blocks: 107067
Keywords: nsbranch-
removing PDT grafitti.
Whiteboard: [nsbeta2-][nsbeta3-]
No longer blocks: 107067
removing myself from the cc list
tested 2002-04-12-08-1.0.0
OS = Win XP Pro. JA
This is not only Win 2000 problem.
It occures on Win XP JA also.
Win XP is major criteria.
This is Win 2000 new feature which is issued more than 3 yeares ago, but  not
supported yet.
This is very poor quality. I added keyword nebeta1.
Bug 36795 is the similar.   
Keywords: nsbeta1
QA Contact: teruko → kasumi
tested 2002-04-12-08-1.0.0
OS = Win XP Pro. JA
This is not only Win 2000 problem.
It occures on Win XP JA also.
Win XP is major criteria.
This is Win 2000 new feature which is issued more than 3 yeares ago, but  not
supported yet.
This is very poor quality. I added keyword nebeta1.
Bug 36795 is the similar.   
nsbeta1-

This needs to be addressed after mozilla 1.0 but not for nsbeta1, there is a
workaround by using keyboard.
Keywords: nsbeta1nsbeta1-
Target Milestone: Future → ---
can't reproduce on 2002-07-17-08-1.0 on Win XP Pro. JA and Win XP Pro. JA SP1 Beta1.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Kasumi, how about Win2k?
tested on 2002-07-24-08-1.0
Win 2000 JA
This incident contents 2 problems.
1.After the step #3, the carret is not at the end of string. -- still
occurred.but this problem is covered by #36975.
2.In step #5, Backspace key does not delete the character.
   Backspace key will change the last 4 characters to hiragana. --  can't
   reproduce.
Step3 still occurred
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I think both roy and me are off mozilla for more than 2 years. If these bugs are
still here now, I think the real stauts is 'won't fix'. If you want to reopen
it, please find a new owner for it first. 
Status: REOPENED → RESOLVED
Closed: 20 years ago17 years ago
Resolution: --- → WONTFIX
Mass Reassign Please excuse the spam
Assignee: tetsuroy → nobody
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
Assignee: jshin1987 → masayuki
Currently, this problem is not reproduced.
Because in step #3, the composition string is commited.
Currently, Mozilla force end composition when user click by mouse.

I think that the behavior that is same as Notepad + IME2000 does not fit to
current build.
-> WONTFIX
Status: NEW → RESOLVED
Closed: 17 years ago17 years ago
Keywords: helpwanted
Resolution: --- → WONTFIX
> Because in step #3, the composition string is commited.

-> Because in step #4, the composition string is commited after click immediately.
                   ^^^
You need to log in before you can comment on or make changes to this bug.