Closed Bug 1871343 Opened 7 months ago Closed 7 months ago

Attachment area not scrollable when there are lots of attachments

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 fixed, thunderbird123 fixed)

RESOLVED FIXED
123 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird123 --- fixed

People

(Reporter: alois.schmid, Assigned: freaktechnik)

Details

Attachments

(2 files)

Attached image Attachments.PNG

Steps to reproduce:

Received e-mail with 200 attachments.

Actual results:

When opening the attachment area, only the first few attachments are visible. No way to scroll down to see or access all attachments. Only way to access attachments is to "Save all..." attachments into a folder

Expected results:

Older versions (before Supernova) had the attachment area scrollable

Assignee: nobody → martin
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 123 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/8cd0f466a6d8
Ensure attachment list properly scrolls overflowing items. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

Good for beta?

Flags: needinfo?(martin)

Comment on attachment 9369884 [details]
Bug 1871343 - Ensure attachment list properly scrolls overflowing items. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): probably flexbox changes
User impact if declined: Attachment list can overflow out of the window, breaking the layout of the entire mail display pane
Testing completed (on c-c, etc.): Patch has been on c-c and c-b a while, tested that it applies to esr (no css nesting!)
Risk to taking this patch (and alternatives if risky): low risk, style change

Flags: needinfo?(martin)
Attachment #9369884 - Flags: approval-comm-esr115?

Comment on attachment 9369884 [details]
Bug 1871343 - Ensure attachment list properly scrolls overflowing items. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for esr115

Attachment #9369884 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: