Closed Bug 1873487 Opened 2 months ago Closed 2 months ago

In Offline mode - send unsent messages has no prompt to go online

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 122
defect

Tracking

(thunderbird_esr115 fixed, thunderbird122 wontfix)

RESOLVED FIXED
123 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird122 --- wontfix

People

(Reporter: anjeyelf, Assigned: mkmelin)

Details

(Keywords: regression, Whiteboard: [TM 115.7.1])

Attachments

(1 file)

Windows 10 OS

In 102* if Offline and you click on 'Sent unsent messages' you would get a pop up prompt which said: " You are currently offline. Do you want to go online to send unsent messages?"

This is not occurring in current release nor in beta 122.0b2 .

Process:

  • In 'Offline' mode
  • Click on 'Write'
  • compose email
  • click on 'Send Later'
  • Email goes to 'Outbox' in 'Local Folders'
  • Right click on 'Outbox'
  • 'Send unsent messages' is enabled - so click on it.

Actual Result
Nothing occurs.
Email still in Outbox.
No pop up prompt.

Expected Result
A pop up prompt which says : " You are currently offline. Do you want to go online to send unsent messages?" with options 'OK' and 'Cancel'

Version: unspecified → Thunderbird 122

Anje, https://mozilla.github.io/mozregression/ can be used to find the regression range

It works via "File > Sent unsent messages", but not, as reported, via the context menu on the outbox. Error console:

Uncaught Error: Component returned failure code: 0x80550014 [nsIMsgSendLater.sendUnsentMessages]
    SendUnsentMessages chrome://messenger/content/mailWindowOverlay.js:1607
    onCommand chrome://messenger/content/about3Pane.js:642
    handleEvent chrome://messenger/content/about3Pane.js:285

0x80550014 is NS_MSG_ERROR_OFFLINE.

Looks like Supernova bustage, the new implementation isn't correct:
https://hg.mozilla.org/comm-central/rev/f1c1efa90b0f#l1.391
Instead of this:
https://searchfox.org/comm-esr115/rev/b21a2c8ee619566dc412c9ed3cc122ce9c0814b7/mail/base/content/about3Pane.js#642
it should likely be running this "goDoCommand('cmd_sendUnsentMsgs')" triggering this:
https://searchfox.org/comm-esr102/rev/e93a5d1c08d70a159a04d1b8cb1e31953889616c/mail/base/content/mail3PaneWindowCommands.js#911-917

The Outbox context menu is working fine for me on daily.

Also fine on 115 (linux).

The menu calls topChromeWindow.SendUnsentMessages(); which fails when offline. The 102 code called goDoCommand("cmd_sendUnsentMsgs"); which issued a prompt for going online first. Are we missing something?

Oh I see it now. I forgot to actually go offline...

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Target Milestone: --- → 123 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/14e4084a4467
Fix 'send unsent messages' on the Outbox context menu when in offline mode. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9372070 [details]
Bug 1873487 - Fix 'send unsent messages' on the Outbox context menu when in offline mode. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): supernova
User impact if declined: in offline mode, outbox send unsent context menu not working
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): safe

Attachment #9372070 - Flags: approval-comm-esr115?
Whiteboard: [TM 115.7.1]

Comment on attachment 9372070 [details]
Bug 1873487 - Fix 'send unsent messages' on the Outbox context menu when in offline mode. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9372070 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.