Closed Bug 1874557 Opened 1 month ago Closed 18 days ago

Regression of bug 1846336: Tag pref observer not registered if automatic updates are not enabled

Categories

(Thunderbird :: Message Reader UI, defect)

Thunderbird 118
defect

Tracking

(thunderbird_esr115 affected, thunderbird123 wontfix)

RESOLVED FIXED
124 Branch
Tracking Status
thunderbird_esr115 --- affected
thunderbird123 --- wontfix

People

(Reporter: betterbird.project+13, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

This line was added into a block that is only executed when automatic updates are enabled:

https://hg.mozilla.org/releases/comm-esr115/rev/719382879ac7#l2.12

This will affect builds which don't have automatic updates enabled.

Keywords: regression
Regressed by: 1846336
Duplicate of this bug: 1877471
Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 124 Branch
OS: Linux → All
Hardware: x86_64 → All

Pushed by solange@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/20aea3121ae0
Add observer for 'mailnews.tags.' correctly - not only inside an MOZ_UPDATER block. r=john.bieling

Status: ASSIGNED → RESOLVED
Closed: 18 days ago
Resolution: --- → FIXED

Comment on attachment 9377605 [details]
Bug 1874557 - Add observer for 'mailnews.tags.' correctly - not only inside an MOZ_UPDATER block. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): bug 1846336
User impact if declined: tag updates not noticed, if no updater is compiled in
Testing completed (on c-c, etc.): c-c, beta
Risk to taking this patch (and alternatives if risky): low

Attachment #9377605 - Flags: approval-comm-esr115?
Summary: Regression of bug 1846336: Tag pref observer not registered if automatic updates are not ebabled → Regression of bug 1846336: Tag pref observer not registered if automatic updates are not enabled
Version: unspecified → Thunderbird 118

Comment on attachment 9377605 [details]
Bug 1874557 - Add observer for 'mailnews.tags.' correctly - not only inside an MOZ_UPDATER block. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9377605 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.