Closed Bug 187521 Opened 20 years ago Closed 20 years ago

RSS feeds don't display as text/plain

Categories

(Camino Graveyard :: Page Layout, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 188130

People

(Reporter: jon, Assigned: bryner)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030101 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030101 Chimera/0.6+

This is kind of hard to explain, but if you view a .rss feed and it is sent via
a Content-type: text/xml header, it renders very ugly in the browser window and
shows up nicely if you view source on it. It would be nicer if it would render
the same as text/plain (or the same as when view source is used).

Reproducible: Always

Steps to Reproduce:
If you take the output of http://studioz.tv/events/calendar.rss and save it to
disk and then use your webserver to send it with a Context-type: text/xml, then
you will see what i'm talking about. Right now, I just check the browser string
and if it is Mozilla, I sent the results back as text/plain...
On mozilla trunk we now do pretty-printing of XML. Chimera will pick it up once 
it moves to the trunk...

*** This bug has been marked as a duplicate of 188130 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.