Closed Bug 1877416 Opened 3 months ago Closed 3 months ago

Firefox is installing components needed to play the audio or video on this page message is displayed three times

Categories

(Toolkit :: UI Widgets, defect)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
124 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox122 --- unaffected
firefox123 --- verified
firefox124 --- verified

People

(Reporter: atrif, Assigned: hjones)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image image.png

Found in

  • 123.0b4

Affected versions

  • 124.0a1 (2024-01-26)
  • 123.0b4

Tested platforms

  • Affected platforms: Windows 10x64, macOS 12, Lubuntu 22.04
  • Unaffected platforms: none

Preconditions

  • New profile

Steps to reproduce

  1. Open https://edition.cnn.com/

Expected result

  • Firefox is installing components needed to play the audio or video on this page message is displayed one time

Actual result

  • Firefox is installing components needed to play the audio or video on this page message is displayed three times

Regression

Additional notes

  • Attached a screenshot.
  • On Lubuntu 22 the Enable DRM message is displayed three times.

:hjones, since you are the author of the regressor, bug 1845150, could you take a look?

For more information, please visit BugBot documentation.

Flags: needinfo?(hjones)

notificationBox.appendNotification is now async, so in cases where we were receiving multiple "cdm-not-installed" messages in quick succession it was possible that the notification from the prior call hadn't actully been appended yet. This made it so that calls to notificationBox.getNotificationWithValue wouldn't return anything, and we would show the same message multiple times. This patch adds code to track which notification related messages are being handled to avoid re-appending the same notification.

Assignee: nobody → hjones
Status: NEW → ASSIGNED
Attachment #9377208 - Attachment description: Bug 1877416 - handle reentrancy when showing infobars via EncryptedMediaParent.receiveMessage r=#recomp-reviewers → Bug 1877416 - handle reentrancy when showing infobars via EncryptedMediaParent.receiveMessage r=#recomp-reviewers,tgiles,mstriemer
Flags: needinfo?(hjones)
Pushed by hjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ba8a1897af6
handle reentrancy when showing infobars via EncryptedMediaParent.receiveMessage r=reusable-components-reviewers,tgiles
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch
Duplicate of this bug: 1876128

The patch landed in nightly and beta is affected.
:hjones, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox123 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(hjones)

Verified fixed with 124.0a1 (20240202094312) on Windows 11x64, macOS 12 and Ubunut 22. Only one message is displayed as expected after following steps from comment 0.

notificationBox.appendNotification is now async, so in cases where we were receiving multiple "cdm-not-installed" messages in quick succession it was possible that the notification from the prior call hadn't actully been appended yet. This made it so that calls to notificationBox.getNotificationWithValue wouldn't return anything, and we would show the same message multiple times. This patch adds code to track which notification related messages are being handled to avoid re-appending the same notification.

Original Revision: https://phabricator.services.mozilla.com/D200030

Attachment #9378597 - Flags: approval-mozilla-beta?

Uplift Approval Request

  • Steps to reproduce for manual QE testing: Open https://edition.cnn.com/ and verify that the message bar shows only once (if at all - may need a fresh profile or build to ensure the plugin isn't already installed)
  • Is Android affected?: no
  • String changes made/needed: No
  • Needs manual QE test: no
  • Explanation of risk level: It's fixing a bug, and that bug isn't relevant on the vast majority of websites
  • Code covered by automated testing: yes
  • User impact if declined: Two bugs were filed for this in nightly, so it's likely more people will notice on release
  • Fix verified in Nightly: yes
  • Risk associated with taking this patch: Low

I've requested uplift to beta: https://phabricator.services.mozilla.com/D200854

Flags: needinfo?(hjones)
Attachment #9378597 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified fixed with Firefox 123.0b8 on Windows 11 x64, macOS 12 and Ubuntu 22. Only one message is displayed as expected after following steps from comment 0.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: