If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when publishing (nsEditor::IsPreformatted)

VERIFIED DUPLICATE of bug 188946

Status

()

Core
Editor
VERIFIED DUPLICATE of bug 188946
15 years ago
15 years ago

People

(Reporter: marina, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
observed with 2003011004 build
i am crashing when attempting to publish with this build. The Incident ID 16035914

Comment 1

15 years ago
Here is a partial stack:
nsEditor::IsPreformatted
[c:/builds/seamonkey/mozilla/editor/libeditor/base/nsEditor.cpp, line 4113]
nsWSRunObject::GetRuns
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsWSRunObject.cpp, line 1002]
nsWSRunObject::nsWSRunObject
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsWSRunObject.cpp, line 92]
nsHTMLEditRules::AdjustWhitespace
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditRules.cpp, line 6611]
nsHTMLEditRules::AfterEditInner
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditRules.cpp, line 460]
nsHTMLEditRules::AfterEdit
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditRules.cpp, line 363]
nsHTMLEditor::EndOperation
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditor.cpp, line 4317]
nsHTMLEditor::LoadHTMLWithCharset
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLDataTransfer.cpp, line 251]
nsHTMLEditor::LoadHTML
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLDataTransfer.cpp, line 179]
nsHTMLEditor::RebuildDocumentFromSource
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditor.cpp, line 1867] 
Component: Editor: Composer → Editor: Core
Summary: Crash when publishing → Crash when publishing (nsEditor::IsPreformatted)
Whiteboard: dupeme

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 188901 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 188946 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
verified dup
Status: RESOLVED → VERIFIED

Comment 6

15 years ago
Marina, I was able to publish a file using the 1-13 linux build but with that
same build I crashed backspacing over the emoticon.  This bug was marked a dup
of that bug, that bug is fixed.  Since I did not see the crash with your bug can
you check this with a 1-15 trunk build to see if your crash is gone too.  Thanks
Esther
You need to log in before you can comment on or make changes to this bug.