backspace on a emoticon will crash the app; trunk [@ nsEditor::IsPreformatted]

VERIFIED FIXED in mozilla1.3beta

Status

()

Core
Editor
--
critical
VERIFIED FIXED
16 years ago
8 years ago

People

(Reporter: esther, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, regression, topcrash})

Trunk
mozilla1.3beta
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using trunk builds 20030113 on linux and winxp if you add a emoticon, then try
to backspace over it the app will crash.
Talkback:
(Reporter)

Comment 1

16 years ago
talkback trace:
nsEditor::IsPreformatted   
[c:/builds/seamonkey/mozilla/editor/libeditor/base/nsEditor.cpp, line 4113]
nsWSRunObject::GetRuns 
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsWSRunObject.cpp, line 1002]
nsWSRunObject::nsWSRunObject 
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsWSRunObject.cpp, line 92]
nsWSRunObject::PrepareToDeleteRange 
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsWSRunObject.cpp, line 154]
nsHTMLEditRules::WillDeleteSelection 
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditRules.cpp, line 1881]
nsHTMLEditRules::WillDoAction 
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditRules.cpp, line 530]
nsPlaintextEditor::DeleteSelection 
[c:/builds/seamonkey/mozilla/editor/libeditor/text/nsPlaintextEditor.cpp, line 959]
nsTextEditorKeyListener::KeyPress 
[c:/builds/seamonkey/mozilla/editor/libeditor/text/nsEditorEventListeners.cpp,
line 259]
nsEventListenerManager::HandleEvent 
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1662]
nsDocument::HandleDOMEvent 
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp, line 3526]
nsGenericElement::HandleDOMEvent 
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 1963]
PresShell::HandleEventInternal 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6159]
PresShell::HandleEvent 
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6082]
nsViewManager::HandleEvent 
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2162]
nsView::HandleEvent 	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 304]
nsViewManager::DispatchEvent 
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1948]
HandleEvent 	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent 
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1119]
nsWindow::DispatchWindowEvent 
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1136]
nsWindow::DispatchKeyEvent 
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3017]
nsWindow::OnChar 	[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp,
line 3211]
nsWindow::ProcessMessage 
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3920]
nsWindow::WindowProc 
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1403]
USER32.dll + 0x3a5f (0x77d43a5f) 	 
USER32.dll + 0x3b2e (0x77d43b2e) 	 
USER32.dll + 0x3d6a (0x77d43d6a) 	 
USER32.dll + 0x3dd0 (0x77d43dd0) 	 
nsAppShellService::Run 
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 471]
main1 	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1559]
main 	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1907]
WinMain 	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1927]
WinMainCRTStartup() 	 
kernel32.dll + 0x1eb69 (0x77e7eb69) 
(Reporter)

Comment 2

16 years ago
Nominating and adding steps.

1. Launch the app
2. launch mail
3. Open an HTML composer window
4. Add a smiley emoticon
5. Backspace over it

Result:
Crash of app
Expected: to backspace over the smiley.
Keywords: nsbeta1, regression
(Reporter)

Comment 3

16 years ago
Note this was OK in the 1-8 trunk build on winxp, regression happened somewhere
between 1-8 and 1-13
(Reporter)

Comment 4

16 years ago
Happens on Mac OSX too.

Updated

16 years ago
Keywords: crash
Summary: backspace on a emoticon will crash the app → backspace on a emoticon will crash the app [@ nsEditor::IsPreformatted]

Comment 5

16 years ago
see also bug 188901.
(Reporter)

Comment 6

16 years ago
These are the same stack trace, but I don't crash when going to the link in that
bug.  Can't edit, but I don't crash with the 1-13trunk builds on my linux or
winxp. However you did get it to crash. Not sure which one should be marked dup
of the other, the bug is in the module editor.dll but is most accessible and
ugly in the mail compose and IM windows (loss of data when composing messages).
 Leaving them as separate bugs for now. 

Comment 7

16 years ago
This is a topcrash on the trunk.  Adding topcrash to keywords.

Here are the comments from todays reports:
     (16145569)	Comments: smiley face.  
     (16139942)	Comments: testing bug 188946.    backspace on emotion-icon
     (16137101)	Comments: backspacing over an emoticon in mail
     (16122806)	URL: http://www.telekom.at
     (16122806)	Comments: alt e -> editor
     (16122738)	URL: http://www.telekom.at
     (16122738)	Comments: choose "edit page" 
     (16035914)	Comments: publishing a file
     (15986952)	Comments: Deleting an emoticon graphic inside an e-mail I was
composing


Keywords: topcrash
Summary: backspace on a emoticon will crash the app [@ nsEditor::IsPreformatted] → backspace on a emoticon will crash the app; trunk [@ nsEditor::IsPreformatted]

Comment 8

16 years ago
This bug was introduced by bryner
-->bryner
Assignee: ducarroz → bryner
Component: Composition → Editor: Core
Product: MailNews → Browser

Comment 9

16 years ago
*** Bug 188901 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 188596 has been marked as a duplicate of this bug. ***
Created attachment 111557 [details] [diff] [review]
wall paper

brade points to bryner because he added the call to ::GetStyleDate() for bug
#114713
Comment on attachment 111557 [details] [diff] [review]
wall paper

r=me. this restores the behavior from before my checkin.
Attachment #111557 - Flags: review+
taking
Assignee: bryner → sspitzer
fixed checked in.

I'll report back with the bug # for the smiley bug where delete doesn't work.

(does editor have a problem with spans?)
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.3beta
the smiley bug is http://bugscape/show_bug.cgi?id=6638

I'll work on moving that to mozilla.

Comment 16

16 years ago
sspitzer: I'm 99% sure there is a bug in bugzilla for deleting the smiley (query
for "smil"?)

Comment 17

16 years ago
The smiley bug--for not being able to delete it with one keypress--is bug 118912.
(Reporter)

Comment 18

16 years ago
Using build 20030115 trunk on winxp, mac osx and linux this is fixed for this
scenario.  I have asked the reporters of the duplicate bugs to check their
scenarios since I could not get it to crash as they did. 
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsEditor::IsPreformatted]
You need to log in before you can comment on or make changes to this bug.