using mouse wheel to scroll, at top and bottom of iframe, main window scrolls

RESOLVED INVALID

Status

()

Core
Event Handling
--
minor
RESOLVED INVALID
15 years ago
9 months ago

People

(Reporter: Banai Lynn Feldstein, Assigned: saari (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

When scrolling in the iframe, if I scroll past the top or bottom, the iframe
stops scrolling, but then the entire page begins scrolling instead.

Reproducible: Always

Steps to Reproduce:
1. Load the bug report page.
2. Click on the iframe of prior reports and scroll with the mouse wheel.
3. Continue scrolling past the bottom -- or reverse and scroll past the top.

Actual Results:  
The iframe reaches its limit at the top or bottom and stops, but the entire web
page then begins scrolling.

Expected Results:  
In normal windows, scrolling past the top or bottom of the window has no effect
-- the scrolling action just stops because the top or bottom has been reached.
Seems to me, this should be the case for the iframe as well. Unless... Is this a
bug or a feature?

Comment 1

15 years ago
IE shows the same behaviour and I find it quite handy. So I think this is the
way it is supposed to work and it is a feature rather than a bug.

Comment 2

15 years ago
have same problem on win2k, it's really annoying (trying to avoid using
mousewheel at all)

I have logitech mouse, it used to work on previous versions of mozilla (at least
I did not run into this problem before).

Comment 3

14 years ago
*** Bug 215452 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
All of my windows browsers behave the same way here. This is not a bug, it's
expected behavior. IE6 and Opera7.5 both do the exact same thing as Mozilla 1.7 RC2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.