Arabic title appear as question marks in title bar of mozilla

RESOLVED DUPLICATE of bug 9449

Status

()

RESOLVED DUPLICATE of bug 9449
16 years ago
11 years ago

People

(Reporter: waleed.hosny, Assigned: mkaply)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

When you try to view an Arabic homepage that have an Arabic title, you will
notice that the title is displayed as question marks in the title bar while it
gets displayed correctly in the tab header.

Reproducible: Always

Steps to Reproduce:
1.open a new browser tab
2.go to www.linux4arab.com


Actual Results:  
you will notice that the title bar content appears as question marks, while the
tab header displayes the title correctly

Expected Results:  
It should display the Arabic title correctly as in the title bar as it gets
displayed everywhere else ( I guess the font selected to display the titlebar
does not contain Arabic gylphs)

Comment 1

16 years ago
Work for me on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030110 under WinXP. Title as in arabic.
(Reporter)

Comment 2

16 years ago
Created attachment 111331 [details]
screen shot

please note the circles that highlight the bug

Comment 3

16 years ago
This bug is 100% same with bug 48169, wich dupe bug 9449. If you read bug 9449
comment #224, you would know, that this bug was fixed after 1.2.1 release. So I
suggest that you upgrade Mozilla.

*** This bug has been marked as a duplicate of 9449 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.