[modern, mac] redundant resize widget in status bar

VERIFIED FIXED in mozilla1.3beta

Status

P1
major
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: dbaron)

Tracking

({platform-parity, regression})

Trunk
mozilla1.3beta
PowerPC
Mac OS X
platform-parity, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch])

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
using the modern theme in OS X (either CFM or mach-o) there are two resize
widgets in the status bar: one underneath the vertical scrollbar, and another to
the left of it. there should be only one.

not a problem with the aqua/classic theme. not a problem on win2k or linux.

screenshot coming up.
(Reporter)

Comment 1

16 years ago
Created attachment 111411 [details]
screenshot of redundant window resize widgets

this is only a problem on mac with the modern theme.

Comment 2

16 years ago
I also saw that as well on Mac os x (netscape trunk build: 2002-01-10-08-TRUNK),
modern theme.

Comment 4

16 years ago
Yes, this makes us look stupid. Another issue is that we now have a special
resize cursor that only shows up for the left-most resize widget. No other Mac
OS X app uses a resize cursor.
Keywords: regression
So..  Are there mac-specific theme files in Modern?  Could we put a rule in
those setting the resizer back to "-moz-appearance: resizer", which is stubbed
out on the mac?

More to the point, perhaps the entire widget should not be there on the mac....

Comment 6

16 years ago
Can we fix this? It really makes Mac builds look stupid, and I think needs to be
fixed for 1.3.
Flags: blocking1.3b?

Comment 7

16 years ago
Why this is evil:
1. Two resize widgets show up in the corner of the window (see screenshot)
2. For the "XP" resize widget, we show a special resize cursor.
3. (Most evil) Because of other bugs, you can move the mouse outside of the
   window, but the resize cursor sticks, thus giving incorrect visual feedback.
   This makes it easy to click, and switch to another app rather than resizing
   the window. This has me cursing several times per day.
Severity: normal → major
Created attachment 113494 [details] [diff] [review]
patch

I tested this in unix/platformXUL.css on my Linux box, and it got rid of the
resizer widget.  Could someone test it on Mac?
Taking bug.
Assignee: shliang → dbaron
Priority: -- → P1
Target Milestone: --- → mozilla1.3beta
Attachment #113494 - Flags: superreview?(sfraser)
Attachment #113494 - Flags: review?(jaggernaut)
Whiteboard: [patch]

Comment 10

16 years ago
Comment on attachment 113494 [details] [diff] [review]
patch

Works for me; tested Modern and Classic. Thanks dbaron!
Attachment #113494 - Flags: superreview?(sfraser) → superreview+

Comment 11

16 years ago
Comment on attachment 113494 [details] [diff] [review]
patch

r=jag
Attachment #113494 - Flags: review?(jaggernaut) → review+
Attachment #113494 - Flags: approval1.3b?

Comment 12

16 years ago
Comment on attachment 113494 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to 1.3beta.
Attachment #113494 - Flags: approval1.3b? → approval1.3b+
Fix checked in to trunk, 2003-02-04 19:00 PST.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Flags: blocking1.3b?

Comment 14

16 years ago
verified on Mac 2003040703
Status: RESOLVED → VERIFIED
QA Contact: pmac → gbush
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.