If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[gtk2] menus from menubar not dismissed when clicking elsewhere in window

RESOLVED WORKSFORME

Status

()

Core
XUL
--
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Mike Gratton, Assigned: David Hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
You should be able to dismiss menus by clicking anywhere else in the window.
This works for popup menus but not for menus from the menu bar.

To reproduce:

1. click on File menu
2. click elsewhere in the window, eg: on the personal toolbar

Expected: File menu dissappears
Actual: File menu remains visible

build #2003010315
Debian/unstable
GTK+ 2.2.0
(Reporter)

Comment 1

15 years ago
This seems to be working properly for me now. Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.