Closed Bug 1893398 Opened 3 months ago Closed 3 months ago

allow converting all tabs to "spaces" buttons on the side

Categories

(Thunderbird :: Toolbars and Tabs, enhancement)

Thunderbird 115
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1839194

People

(Reporter: amanita+BUGZILLA, Unassigned)

Details

Steps to reproduce:

As far as I understood your idea, the side panel is meant to replace tabs.

Tabs are using up vertical space, which is not really nice. I think the spaces buttons are a good idea.

Actual results:

Problems:

  • there are only a few categories

available: Mail, contacts, calendar, tasks, settings
missing: addons, "mail in new tab", "omni search", account settings, addons.thunderbird.net, ...

  • the buttons open a new tab

Expected results:

The buttons work like tabs. This means, if

  1. all the missing categories get a button (this does not need to be shown in the bar, but it needs to be possible to a appear and work)
  2. there is a placeholder button for unknown tabs (fallback)
  3. there is a way to remove certain buttons, pin them and close them

then the sidebar can replace tabs.

I think if the sidebar should be kept, this is the only good solution.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Duplicate of bug: 1839194
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.