Closed Bug 1896009 Opened 2 months ago Closed 2 months ago

POP3 Inbox scroll position always on mail #2 since 115.10.1

Categories

(Thunderbird :: Folder and Message Lists, defect, P1)

Thunderbird 115

Tracking

(thunderbird_esr115+ fixed, thunderbird127 fixed)

RESOLVED FIXED
128 Branch
Tracking Status
thunderbird_esr115 + fixed
thunderbird127 --- fixed

People

(Reporter: klk745, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [regression: 115.10.0])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:125.0) Gecko/20100101 Firefox/125.0

Steps to reproduce:

115.10.1 introduced a strange bug for me:

  1. Start TB or let TB load new e-mails into the inbox.

Actual results:

TB starts with the top scroll position of the inbox set to mail #2.
That way the first/freshest mail is always "invisible" and I need to scroll up.

Expected results:

TB should always scroll to the first mail in the inbox, not the second, like it was the case before 115.10.1.

A research on the web revealed at least three other users with exactly the same problem in this thread on a german TB forum:
https://www.thunderbird-mail.de/forum/thread/94527-ansicht-posteingang/?pageNo=1

Addendum: it seems to only affect POP3 inbox folders. Inbox folders for IMAP accounts scroll to the first mail, as it used to be before this regression. (confirmed by at least two other users in the aforementioned forum)

Steps to reproduce (in TB 115.10):

  1. Select a local folder with a bunch of messages sorted by date, descending, without any persisted selection.
  2. Select "Local folders" in the folder pane.
  3. Select the local folder itself again.
  4. Repeat steps 2 and 3.

Expected result:
When the local folder is selected, the topmost message is always scrolled into view.

Actual result:
Every other time the local folder is selected, the the view is not scrolled all the way up to the top.

If you switch back and forth between an IMAP folder and the account it belongs to, the view will scroll to the top, but visibly only after a short delay.

Status: UNCONFIRMED → NEW
Component: Untriaged → Folder and Message Lists
Ever confirmed: true
Keywords: regression
Regressed by: 1883550
Summary: Inbox scroll position always on mail #2 since 115.10.1 → POP3 Inbox scroll position always on mail #2 since 115.10.1

Regression window

Backing out this revision from comm-esr115 resolves the issue.

I understand what's happening here. Not sure why it doesn't appear to happen on beta, but there's been several other changes to the message list loading there.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Priority: -- → P1

When the view gets hidden, the resize observers are informed that its height is 0. Consequently
when it becomes unhidden, some calculations are performed using a cached height of 0, before the
resize observers are updated.

When the header itself is hidden, we DO cache a height of 0, because that is the actual height.

Whiteboard: [regression: 115.10.0]
Target Milestone: --- → 128 Branch

Pushed by benc@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/8f0d035dc97e
Ignore changes to TreeView header height when the view is hidden. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1895031

Will this be fixed in the 115 ESR series as well?

Comment on attachment 9401543 [details]
Bug 1896009 - Ignore changes to TreeView header height when the view is hidden. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): bug 1883550
User impact if declined: message list starts at the wrong scroll position in some circumstances
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):

Attachment #9401543 - Flags: approval-comm-beta?

Comment on attachment 9401543 [details]
Bug 1896009 - Ignore changes to TreeView header height when the view is hidden. r=#thunderbird-reviewers

[Triage Comment]
Approved beta

Attachment #9401543 - Flags: approval-comm-beta? → approval-comm-beta+

"The bug is reproducible on 115 by switching between a large local or POP3 folder (newest at top) and the account's root folder. It doesn't really happen on central, so you might want to copy these changes to 115 to test it works."

Are you suggesting we should uplift to 115?

Flags: needinfo?(geoff)

Comment on attachment 9401543 [details]
Bug 1896009 - Ignore changes to TreeView header height when the view is hidden. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): bug 1883550
User impact if declined: message list starts at the wrong scroll position in some circumstances
Testing completed (on c-c, etc.): in 127.0b3
Risk to taking this patch (and alternatives if risky): low

(yes)

Flags: needinfo?(geoff)
Attachment #9401543 - Flags: approval-comm-esr128?

Comment on attachment 9401543 [details]
Bug 1896009 - Ignore changes to TreeView header height when the view is hidden. r=#thunderbird-reviewers

Bah, wrong flag.

Attachment #9401543 - Flags: approval-comm-esr128? → approval-comm-esr115?

Comment on attachment 9401543 [details]
Bug 1896009 - Ignore changes to TreeView header height when the view is hidden. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9401543 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: