Inconsistent sorting of incoming mail by columns. Or should I say primitive.

RESOLVED DUPLICATE of bug 57898

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 57898
15 years ago
12 years ago

People

(Reporter: georg wrede, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

"Bad example:" Sorting of mail sucks!
Better example: You should be able to use either the beginning or the end
of the mail list window -- consistently! 

Ok, some people want to see the newest at the top, some at the end. At first 
thought both groups should be accommodated as fluently as possible. (Not the
current situation for either!) Below, I'll examine only the former. (Most of
the problems are relevant for both groups.)

Now, some people really use an IMAP account for the express purpose of 
NOT having to remove already read messages. The mail account serves as a
repository of mails. This gives the advantage of being able to see the 
whole archive from any geographic location. People having only 20 mails
in their inbox can't understand this bug report. Some ISPs even encourage
this approach! (Today, I have 4999 mails in the inbox. Anybody who says this
is dumb is welcome to exchange opinions with me by email.) My provider,
however, does not let us create mail folders on the server. This seems 
to be a common practice with those who let you have a "large" amount of mail.

Reproducible: Always

Steps to Reproduce:
(No setup steps are used here.) Precondition: you want to see the newest mails
at the top, and you want to consistently use the top of the list for all
operations you do on multiple messages.

1. (Single/double) click on Date to sort newest first. 
2. Flag a few messages.
3. Click on Flag column header to sort together the flagged messages.

Actual Results:  
You see your flagged messages at the top, followed by the oldest-ever mails
and your other new-ish mails at the very bottom.

(BTW, another click on Flagged does not help,
you then have the same situation at the other end of the list! (I.e. your
new, flagged messages next to the very oldest on the list.)

Expected Results:  
At the very least, the previous sort order should be kept when sorting by
boolean columns (i.e. read, flagged).

HOWEVER, "keeping previous order within new sort" is not a solution, it is
merely something you, althoug you SHOULD have it, is something you only have
on top of an already ERGONOMIC and FLUENT mail list browser window.

1. We all want the mail browser to be so ergonomic and usable that nobody pays
any attention to it -- like any good software. This is called Quality.

2. The mail browser has had several conceptual bugs in the sorting during all 
the years that Netscape has been around, causing a lot of people to get used
to behavioural work-arounds that have become second nature to them. (Example:
many users now have the newest at the bottom, which is bad, because the menu 
and the toolbar are at the top.)

3. While at first thought this issue might be subtle, or even trivial, it is
of great value to the overall usability and experience of using Mozilla/
Netscape. Currently I suspect the sorting is more or less only a result of
just "having a column-sortable table widget around", instead of any research,
or even plain old Thinking about the issue.

//////////

Your form never asked for suggestions for improvement. I am willing to 
discuss issues (pertaining to this particular problem) with developers, per
e-mail.

Regrettably, I'm not a Real Programmer, so I cannot just resolve the issue,
and let you decide whether to include it.

Comment 1

14 years ago
Georg Wrede, it appears you are asking for multiple, independent sort criteria. 
This is bug 57898; if you agree, please mark this bug as a duplicate of that 
one.

See also bug 181143.

Comment 2

14 years ago
No response from reporter; duping.

*** This bug has been marked as a duplicate of 57898 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.