Title element is not supported properly.

RESOLVED DUPLICATE of bug 118704

Status

()

--
major
RESOLVED DUPLICATE of bug 118704
16 years ago
10 years ago

People

(Reporter: croo, Assigned: jst)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Researching bug 181921 and bug 155521 lead me to a strange conclusion:
HTMLTitleElement is noncence, it could not be use it Mozilla. Testcase show,
that this element not supported id, lang and dir (in contrary with HTML 4.01
standart), and bug 181921 show, that document.title does not depend on this element.

As I think, source of such behaviour, is that change of document.title not
linked to document.getElementByTag("TITLE").item(0), even more, function
nsDocument::SetTitle(const nsAString& aTitle) does not fire change of Tittle
text (in other direction fic for bug 1415 work, so if I change
document.getElementByTag("TITLE").item(0).text document.title changed). 

I do a small overview of other title bugs, and found that bug 33878 marked
fixed, although no dir, lang or id propereties of <title> is supported.
(Reporter)

Comment 1

16 years ago
Created attachment 111996 [details]
Support of HTMLTittleElement
(Reporter)

Comment 2

16 years ago
Oh, also it cover bug 118704. 

And, if document have no title tag his title could not be changed -- this is
because   if (!title.IsEmpty()) 
(in nsDocument::SetHeaderData function) have no else. So empty titled document
could not obtain title with document.title="something"
(Assignee)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 118704 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.