Closed Bug 1897636 Opened 29 days ago Closed 19 days ago

Crash in [@ IPCError-browser | GPUProcessKill]

Categories

(Core :: Graphics, defect)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
128 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox126 --- unaffected
firefox127 --- unaffected
firefox128 --- fixed

People

(Reporter: gsvelto, Assigned: alwu)

References

Details

(Keywords: crash, topcrash, topcrash-startup)

Crash Data

Attachments

(1 file)

Crash report: https://crash-stats.mozilla.org/report/index/ef27fe0f-5027-4d1e-bf5f-09a620240519

Reason: EXCEPTION_BREAKPOINT

Top 10 frames:

0  ntdll.dll  NtWaitForSingleObject
1  KERNELBASE.dll  WaitForSingleObjectEx
2  xul.dll  mozilla::mscom::EnsureMTA::SyncDispatchToPersistentThread(nsIRunnable*)  ipc/mscom/EnsureMTA.cpp:172
3  xul.dll  mozilla::mscom::EnsureMTA::SyncDispatch(nsCOMPtr<nsIRunnable>&&, mozilla::msc...  ipc/mscom/EnsureMTA.cpp:185
3  xul.dll  mozilla::mscom::EnsureMTA::EnsureMTA(mozilla::WMFDecoderModule::Init::<lambda...  ipc/mscom/EnsureMTA.h:73
3  xul.dll  mozilla::WMFDecoderModule::Init(mozilla::WMFDecoderModule::Config)  dom/media/platforms/wmf/WMFDecoderModule.cpp:132
4  xul.dll  mozilla::PDMInitializer::InitGpuPDMs()  dom/media/platforms/PDMFactory.cpp:90
4  xul.dll  mozilla::PDMInitializer::InitPDMs()  dom/media/platforms/PDMFactory.cpp:199
5  xul.dll  mozilla::PDMFactory::EnsureInit::<lambda_0>::operator()() const  dom/media/platforms/PDMFactory.cpp:316
5  xul.dll  mozilla::detail::RunnableFunction<`lambda at /builds/worker/checkouts/gecko/d...  xpcom/threads/nsThreadUtils.h:548

I'm not sure what's going on, but it appears to be a new signature, so maybe a regression?

The bug is linked to a topcrash signature, which matches the following criterion:

  • Top 10 desktop browser crashes on nightly (startup)

For more information, please visit BugBot documentation.

About half of these have WMFDecoderModule stuff in the stack like in comment 0, which I think would make this Audio/Video: Playback. The other half (like this one bp-cfc521dd-26df-4c6e-b626-48e3c0240520) have only generic windows event loop stuff in the stack so I'm not sure if that's the same thing or not.

:alwu, do you have any idea about the crash?

Flags: needinfo?(alwu)

The earliest crash signature appeared on May 15th on Fx128, and we started adding GPUProcessKill in bug 1880503 around that time. That can explain why this signature didn't show up before, but it didn't explain why the crash would happen. This crash seems related with the IPC timeout, and PDMFactory performs initialization on the main thread, which could take too much time and cause the time out.

In bug 1885671, we already move the decoder module's initialization off the main thread, and we could do the same thing here as well.

Assignee: nobody → alwu
Flags: needinfo?(alwu)
See Also: → 1880503, 1885671

Since bug 1885671, we no longer need to run the initialization for
decoder module on the main thread, so we should allow running
InitPDMs() on non-main threads as well.

Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6aa6da68d232
allow the initialization for PDMs on any thread. r=media-playback-reviewers,padenot
Status: NEW → RESOLVED
Closed: 24 days ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch
Flags: needinfo?(alwu)
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/182c1293f1ae
allow the initialization for PDMs on any thread. r=media-playback-reviewers,padenot
Status: REOPENED → RESOLVED
Closed: 24 days ago19 days ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch

None of crashes happened after landing my patch [1] is related with media stack, so we can file another bug to keep tracking other crashes sharing the same signature.

[1]
https://bit.ly/3X0lbGg
https://bit.ly/4dYijjj
https://bit.ly/3X433LW

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: