Cannot change default search engine.

RESOLVED DUPLICATE of bug 128081

Status

--
major
RESOLVED DUPLICATE of bug 128081
16 years ago
11 years ago

People

(Reporter: mozilla, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20021216
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20021216

Clicking on Search always takes me to
http://wp.netscape.com/escapes/search/ntsrchrnd-3.html?cp=ntserch& no matter
which default search engine is checked under Edit/Preferences/Internet Search. I
want to use Google, but have tried others as well.

James Messick

Reproducible: Always

Steps to Reproduce:
1.Change default search engine
2.click on search
3.

Actual Results:  
goes to http://wp.netscape.com/escapes/search/ntsrchrnd-3.html?cp=ntserch&, always

Expected Results:  
Changed search engine to google.

Comment 1

16 years ago
I've never had this prob, even with older builds. Corrupt profile?


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030117 WebWasher 3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030117 WebWasher 3.0
You probably have keywords enabled, that's why it takes you to Netscape. So far,
there's no alternative implemented so that the internet keywords go to your
default search engine.

*** This bug has been marked as a duplicate of 128081 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
REOPEN:
The search button is not hooked into the keyword.url pref (which is used for
internet keywords). I don't understand search enough to tell you what is is
really hooked into.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.