After using Ctrl+G to "Find Again" in Bookmarks, pressing Enter launches previously selected bookmark item

VERIFIED INVALID

Status

SeaMonkey
General
P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: jklenk, Assigned: leger)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
This has been happening as far back as I can remember, and it's always really
bothered me (since I greatly prefer the keyboard over the mouse).

1.)  Go into bookmarks.
2.)  Do a single Find (Ctrl+F), using search criteria that will match multiple
bookmarks.  For instance, do a search on "http".
3.)  The first item found will be correctly highlighted and selected (you can
see the dotted outline above and below it).
4.)  Do a Find Again (Ctrl+G).  The next matching bookmark is correctly found
and highlighted.  However, it is *NOT* selected.  You can see that the first
bookmark that was found with the Ctrl+F search still has the dotted outline.

At this point, if you use an up/down arrow key or press Enter (etc...), then
your keyboard input will be acting on the first found bookmark, not the
highlighted one.

This is annoying, because I have to keep switching between keyboard and mouse (I
have to click on the second found bookmark before being able to load it with the
Enter key).

Comment 1

19 years ago
*** Bug 19016 has been marked as a duplicate of this bug. ***
Is this a bug in 4.x or Mozilla?
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
Reporter responded by email:

>In a message dated 12/6/99 11:37:17 PM Eastern Standard Time,
>bugzilla-daemon@mozilla.org writes:
>
>> + Is this a bug in 4.x or Mozilla?
>
>
>It's a bug in 4.x.  I don't have Mozilla... I guess I reported the bug in the
>wrong place (someone told me to report it there).
>
>John

Marking INVALID.
The correct place to report 4.x bugs is
http://help.netscape.com/forms/bug-client.html .
(Assignee)

Comment 5

18 years ago
Marking Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.