Give me a(n easy) way to start multiple instances of Mozilla so a crash in any Mozilla window does not close all my windows/tabs.

RESOLVED DUPLICATE of bug 135137

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 135137
15 years ago
13 years ago

People

(Reporter: rhkramer, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Summary said it pretty well -- I may elaborate a little:

See also bug (rfe) 190716 -- Mozilla does crash, I don't think anybody will ever
fix it so it can't crash, thus I need some ways to mitigate the interruption to
my work as the result of a crash.  One suggestion is covered in 190716 (a
manager to let me restore Mozilla to its state before a crash.

Digression: I guess I'm now aware of 4 ways of setting up a program in Windows /
Linux -- SDI, MDI, MSDI (AFAICT an AbiWord innovation -- you can have multiple
instances of AbiWord windows, but they all look like the SDI approach and you
can have multiple instances of AbiWord (not all the open windows run from the
same instance of code).  It looks like Mozilla goes one better -- sort of the
MSDI (if I can say that windows / tabs is analogous to single / multiple
documents), but Mozilla runs all of them against a single instance of the
program (AFAICT) so a crash that closes any tab or window closes them all.  At
least in AbiWord I can "force" separate program instances so that not all work
is lost as the result of a crash.  (The "forcing" is not difficult -- if I open
a new document from within another open document, I get a new window within the
one instance.  If I start AbiWord from the CLI (for example) I get a new
instance of AbiWord, complete.  I can't do that in Mozilla (at least in Mandrake
8.2 and 9.0).

Reproducible: Always

Steps to Reproduce:
1.  Do something to cause a crash in any tab / window.  All Mozilla tabs and
windows close.  (I can cause Mozilla to crash by opening a large number of tabs
and windows (like 15 windows with an average of 10 tabs each) or by visiting
certain pages -- I'll try to find one that is repeatable -- but, that's sort of
beside the point.
2.
3.

Actual Results:  
After a crash in any Mozilla tab or window, all Mozilla tabs or windows are
closed and any work in progress on a form or text box is lost.

Expected Results:  
Allow me to start multiple instances of Mozilla, so after a crash of any
instance, the windows and tabs in the other instances remain visible and usable.
 (I don't expect a separate instance for each of 15 windows, but the ability to
reduce the risk / damage by perhaps starting 3 instances with 5 windows each,
and perhaps another instance for unknown or "hazardous" pages.

*** This bug has been marked as a duplicate of 135137 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Also see bug 61942 and bug 63004.
(Reporter)

Comment 3

15 years ago
This bug is *not* a duplicate of this Bug 135137 -- far from it -- in most
respects it seems almost the opposite.

My problem is this:  In Mozilla 1.1 (Mandrake 9.0) when any portion of Mozilla
crashes, all my open Mozilla tabs and windows close.  (Since it is not untypical
to have 150 tabs open spread across 15 or so Mozilla windows, and some of those
windows may have open "text boxes" for editing TWiki pages, I lose a significant
amount of work and context.)

It seems no matter how I open Mozilla, only one instance is created.

In one of the comments to Bug 135137 it is stated that this is how applications
in Windows behave.  It is not, at least as of Win95, and if it has changed it is
a change for the worse.  The truth is that in Windows there are ways to open new
copies of an application so they are new windows/tabs of the same instance and
there is a way(s) to open an application so a new instance is created.

In Windows (95), if you open a new application window by entering the
application name on the command line, clicking the icon, or clicking on the
start menu entry, you get a new instance of the application that shares nothing
with the previous instance.  (Well, that statement may be a little too strong --
it presumably shares the preferences and things like that.)  The point is, a new
instance of the program is created, and if some other instance of the program
crashes, this new instance does not crash (unless the crash kills all of Windows).

On the other hand, if you go into an open window or tab of a running instance of
a program and click New (or Open??), you create a new Window or Tab that is part
of the existing instance.  If something happens to cause a crash of this new
window, all open windows and tabs that are part of this instance close, but
those that are part of some other instance remain open and functional.

IIUC some other people are pushing for improvements or changes to the single
instance behavior.  My bug (RFE) is requesting that there be a means to create
multiple instances.

Is it clear?

If so, I think somebody needs to rewrite some bugs or create some "meta bugs" to
properly collect the votes.  (Note that the two behaviors I describe above are
not mutually exclusive -- there should be a means to do both, and at least
knowledgable users should be aware of how to do both.)

I first created these comments on Bug 135137.  I have now copied and pasted
there here with a few changes to hopefully keep the proper context.  I will now
 attempt to reopen this bug.  Please don't close it as a duplicate of bug 135137
again -- perhaps there is some other bug that it is truly a duplicate of, but
it's not 135137.

Or, another way of saying what I'm trying to say -- the writeup on bug 135137 is
so confusing, it's hard to tell what it is about.  If my bug truly is a
duplicate of this bug, bug 135137 needs to be rewritten (a new "meta bug") very
clearly, and all the comments to bug 135137 that confuse the issue need to be
discarded.

Randy Kramer
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
It's not the opposite, it's that bug.
You want more than one instance and you can't do that with the same profile
unless bug 135137 is fixed.

YOU can currently open multible instances if you use more than one profile.
If you want to create a instance with a GUI option (open in new window as new
instance) = wontfix

reduping and if you reopen = wontfix
(unless you make a SHORT comment what do you want and not 3 pages)

*** This bug has been marked as a duplicate of 135137 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
Randy, I agree with Matti that this is a duplicate, as he marked it. 

I just wanted to say that, in addition to your suggestion, there is alternate
way to protect data in Mozilla from the problem you describe. The first step
would be to autosave URIs, and the second would be to autosave all form data as
they are typed in. There are open bugs for these, I think. With such a scheme,
after a crash, you should be able to just click a menu option, then Mozilla
would open all the windows, tabs, and URIs that it had open before, and refill
all form data.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.