All users were logged out of Bugzilla on October 13th, 2018

Make address type drop down list (e.g. To: Cc: etc) hot keys

VERIFIED DUPLICATE of bug 175060

Status

--
enhancement
VERIFIED DUPLICATE of bug 175060
16 years ago
10 years ago

People

(Reporter: stevemc, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Netscape 4.x mail client used to let me type a leu to change the email address
type (type "C" for example to change from To: to Cc:) if the focus is on the
address type drop down list.  With Mozilla 1.2 I have to type the arrow keys. 
It appears things are getting better in Mozilla 1.3 since now you can type a key
to select an item in that list but you have to pop-down the dropdown list first.

What I would like to see is this:
If the focus is on the email address type field (e.g. To:, Cc:, etc) then I can
type the first letter of each entry (e.g. C or T) and have that item selected
without having to first pop the dropdown list up. 

Reproducible: Always

Steps to Reproduce:
1.To reproduce, type and address in one of the fields 
2.Press Shift-Tab to move the mouse focus to the address type dropdown list.
3. Try to type "C" to change the dropdown to "Cc:" or "T" to chagne to "To:".


Actual Results:  
Typing keys other than the arrow keys does nothing until you first open the
dropdown list.

Expected Results:  
Ideally you would be able to type 'C' to change the dropdown to "cc:" or "T" to
change the dropdown to "To:".  


This is by no means a critical feature.  However, it was one of those
"niceities" that I really appreciated about NS4.x (not having to take your
fingers off the keyboard for common tasks).

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 175060 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Make address type drop down list (e.g. To: Cc: etc) hot keys → Make address type drop down list (e.g. To: Cc: etc) hot keys

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.