Advanced JavaScript Options shows wrong status

VERIFIED FIXED

Status

()

Firefox
Preferences
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: noririty, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20030201 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20030201 Phoenix/0.5

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20030201 Phoenix/0.5
[Tools]-[Options]-[Web Features]-[x]Enable Javascript-[Advanced]
“Advanced JavaScript Options Dialog’s Checkbox” shows opposite meaning to actual
action.

Reproducible: Always

Steps to Reproduce:
1.Start Phoenix with a new profile.
1.Open [Tools]-[Options]-[Web Features]
2.Click Enable Javascript-[Advanced]
Actual Results:  
Allow scripts to:
[ ]Move or resize existing windows
[ ]Raise or lower windows
[ ]Hide the status bar
[ ]Change status bar text
[ ]Change images

Expected Results:  
Should indicate actual preference, like the old version of phoenix do:
Allow scripts to:
[X]Move or resize existing windows
[X]Raise or lower windows
[X]Hide the status bar
[X]Change status bar text
[X]Change images
(Reporter)

Comment 1

15 years ago
ben: Please fix this bug.
Keywords: regression

Comment 2

15 years ago
Reassigning to Ben and confirming.
Assignee: blaker → ben
Blocks: 191524
Status: UNCONFIRMED → NEW
Ever confirmed: true
Fixed. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

15 years ago
Thank you Bob. Now it works for me with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030202 Phoenix/0.5
and VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.