If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

dropdown menus on www.iplanet.com don't work - mouseMove() bug?

VERIFIED DUPLICATE of bug 9140

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 9140
18 years ago
16 years ago

People

(Reporter: vocatan, Assigned: joki (gone))

Tracking

({testcase})

Trunk
x86
Other
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Just downloaded milestone M11 on WindowsNT

I went to the new, updated www.iplanet.com page.

On Communicator, this page has a bunch of hotspots along the top of the screen.
Moving the mouse over "Support", for instance, brings a dropdown list. This
works on Mozilla-M11, but I can't move the mouse down to select an element from
the list.

This is not expected behaviour.

Updated

18 years ago
Assignee: rickg → joki

Comment 1

18 years ago
Tom -- this bug is legit. If you don't think it's yours, can you reassign it AND
let me know who gets it so I can do direct assignments better. Thanks.

Updated

18 years ago
Whiteboard: [MAKINGTESTCASE] jelwell@singleclick.com

Comment 2

18 years ago
Created attachment 3701 [details]
Simplified TestCase that demonstrates bug.

Updated

18 years ago
Whiteboard: [MAKINGTESTCASE] jelwell@singleclick.com → [TESTCASE]

Comment 3

18 years ago
I posted a test case.
The expected results is when you mouse over the blank image (I should have used
a non blank image. the image is at the top right corner though.) Mozilla should
pop up an alert box that says "hit menu". But basically what is happening is the
onMouseOver property of the client side image map is being ignored by Mozilla
but not Netscape 4.x.
Joki, can I help fix this?  Not that I'm looking for more to do for M13....

/be

Comment 5

18 years ago
Isn't this bug actually the same as 10084 which states that A is not supported
in client-side image maps?

Comment 6

18 years ago
I have created a testcase to test all 12 events that image-map elements are
expected to support (according to the W3C:
http://www.w3.org/TR/html4/struct/objects.html#h-13.6 ). It is at:
http://www.achiew.com/bri/image_map_test/image-map-2.html
(I haven't added this as an attachment as I have been experiencing problems
viewing attachments recently).

So far, IE5 performs best, supporting all but the keypress related events (just
so that you know the testcase is valid).
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase

Comment 8

18 years ago
Have added my testcase as an attachment to bug 24041 ( 
http://bugzilla.mozilla.org/show_bug.cgi?id=24041 ). Probably should have 
attached it to this bug, oh well.

Testcase for all 12 events iamgemap elements are expected to support: 
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=4631
Using Feb 29, 2000 mozilla build on WINNT
jelwell@singleclick.com  1999-12-21 test case works.
The http://www.iplatnet.com site doesn't seem to have dropdowns anymore

using brian@achiew.com  2000-01-27 16:57 testcase

I replaced the alert() call to dump() to eliminate any problems with bringing up 
the alert box.
On WIN32 with Feb 29,2000 build the following works:

onclick 
onmouseodwn
onmouseover 
onmouseout 
onfocus 
onmousemove 

The following fails:

ondblclick fails it is triggered on a single mouse click;
onkeydown fails - does nothing
onkeyup fails - does nothing


It looks like http://www.iplanet.com/ has changed, the dropdown lists are no 
longer displayed in 4.x. The rest of this bug is covered by 9140 so I'm marking 
it a dup of that bug. The original test url (http://www.iplanet.com/) may have 
had more in it, but its gone now.

*** This bug has been marked as a duplicate of 9140 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 11

18 years ago
VERIFY duplicate
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.