charset and hence content of subject changed upon reply/followup (different charset in subject and body)

VERIFIED DUPLICATE of bug 115096

Status

--
major
VERIFIED DUPLICATE of bug 115096
16 years ago
10 years ago

People

(Reporter: 3.14, Assigned: bugzilla)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030117
(also seen in Windows version)

If I reply to a mail/posting with the following subject, it is changed to
iso-8859-1:
Subject: =?ISO-8859-5?Q?=C7=E2=DE_=DF=E0=DE=D1=DB=D5=DC=D0=3F?=

Of course, the new subject does not make any sense.

In this test case the body has been in ASCII. If the body is utf-8 the Subject
just becomes:
Subject: Re: =?UTF-8?B?57+9?=

Everything is OK, if the body has iso-8859-5.

If the body is iso-8859-1, then we get the same result as for ASCII.

The error already happens when composing. This bug is evil. If you correct the
subject by hand, Mozilla readily sends everything, so we could do it right.

And BTW: This breaks GNKSA which requires that the subject is not changed.

pi

Comment 1

16 years ago
Yes, this was recently discussed on USEFOR -- the Subject shouldn't 
have it's charset changed unless the user changes content of the header.

Except for the addition of "Re: " if necessary and the possible deletion of 
"(was: .+", the Subject that comes in should byte for byte the Subject that 
goes out, unless the user makes a change (at that time your free to 
change the encoding to fit what the user is using).

(I'd also recommend raw UTF8 instead of the 2047 encoding shown, but 
that's a different matter).
(Reporter)

Comment 2

16 years ago
>Yes, this was recently discussed on USEFOR -- the Subject shouldn't 
>have it's charset changed unless the user changes content of the header.

Well, this is not the point of my report. If it would be a correct recoding
(like changing ISO-8859-5 to UTF-8) that would be OK. This change without
recoding does change the content.

>Except for the addition of "Re: " if necessary and the possible deletion of 
>"(was: .+", the Subject that comes in should byte for byte the Subject that 
>goes out, unless the user makes a change (at that time your free to 
>change the encoding to fit what the user is using).

Which would also mean to preserve real bad subjects (unnecessary binary
encoding, MIME where it is not needed, bad folding, mixed charsets etc.).
Anyway, if you want it, please use a new bug (if there is none so far).

>(I'd also recommend raw UTF8 instead of the 2047 encoding shown, but 
>that's a different matter).

I don't know any RfC which would allow that. Maybe if USEFOR comes to some
result, which I personally would not expect before 2137, probably later. But
again: Not this bug.

pi
(Reporter)

Updated

16 years ago
Summary: charset and hence content of subject changed upon reply/followup → charset and hence content of subject changed upon reply/followup (different charset in subject and body)

Comment 3

16 years ago
looks like duplicate of 115096
(Reporter)

Comment 4

16 years ago
You are right.

BTW: If you write "bug 115096" instead of only the number, it becomes clickable.

pi

*** This bug has been marked as a duplicate of 115096 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.