download a directory at once, using save link as

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
16 years ago
3 years ago

People

(Reporter: dale.r.kalsow, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

Can connect to an ftp site and download individual files but if I want an entire
directory I have to do each file indivually.  Would like to be able to download
entire directory.

Reproducible: Always

Steps to Reproduce:
1. Go to an FTP site.
2. Right click a directory and you do not get any way to download the directory.
3.

Actual Results:  
Can not get entire directory.

Expected Results:  
Give you an option of "Save Folder To".  This would copy the entire folder from
the ftp site and save it to the specified local directory.
-> FTP
Assignee: asa → dougt
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: FTP
Ever confirmed: true
QA Contact: asa → benc

Comment 2

16 years ago
+clean-report
I don't think the ftp URL format supports this, so it is doable, but would need
to appear as some kind of UI widget/button somewhere.

Some servers use an auto "request the dir in compresssed format" feature, see
bug 91292.
Keywords: clean-report
OS: Windows XP → All
Hardware: PC → All
Summary: When connected to an FTP site I can down load a file but would like to download a directory. → download a directory at once

Comment 3

16 years ago
this has nothing to do with the ftp URL or 91292. 

i understand the requirement - download the contents of a directory.  what would
be nice is to have someone wanting to build a very powerful ftp client, until
than ftp RFE's are future.  Thanks again for your suggestion.
Target Milestone: --- → Future

Comment 4

16 years ago
I think this download-a-whole-directory feature is very convenient.
And MS IE has supported a same feature though intigrated with system Explorer.

Comment 5

15 years ago
FYI - Bug #245791 about "Unable to upload a folder / directory".  These two bugs
now have one thing in common.

Updated

15 years ago
Blocks: 245908

Comment 6

14 years ago
This RFE of downloading an entire directory at once has been asked by another 
customer called Dessau-Soprin. 

Comment 7

14 years ago
*** Bug 281909 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 392292
Summary: download a directory at once → download a directory at once, using save link as

Comment 9

11 years ago
mass reassigning to nobody.
Assignee: dougt → nobody

Updated

3 years ago
Duplicate of this bug: 1166912
only critical ftp changes at this point
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.