Closed Bug 193560 Opened 18 years ago Closed 16 years ago

comma at the number-block is coming out as | - sign

Categories

(Core :: DOM: Editor, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 108170

People

(Reporter: m.blassnig, Assigned: mozeditor)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2.1) Gecko/20021130

the bug is the same when using mozilla 1.0 (english) and mozilla 1.2.1 (german)/
when pressing the comma(decimal-sign) on the number-block, no "," appears but
"|". this bug appears only in mozilla, when writing into the address-line or any
input-field (e.g. money-amounts in internet-banking)
OpenOffice works ok.

Reproducible: Always

Steps to Reproduce:
1.SuSE Linux 8.1 installed, keyboard (Logitech i-Touch) german
2.installed the mozilla-packet 1.0 from CD (english)
3.starting mozilla (no special settings)

Actual Results:  
the decimal-key on number-block is coming out as "|" in address line or
input-lines of the browser

Expected Results:  
mozilla should show a "," for decimal-sign in input-lines or input-fields
(keyboard german)
WFM using a 2003-02-15 cvs build on RedHat 8.0 w/ KDE 3.0 and xmodmap (to
replace the numblock "." with ",").

Does the comma work on an xterm?
Summary: komma at the number-block is coming out as | - sign → comma at the number-block is coming out as | - sign
From email by Meinhard:

The komma works on an xterm! 
I am using KDE3 and I have no problems with this komma except mozilla and 
xcalc. kcalc is working properly - I use this calculator because of the 
following reason: When using xcalc I have to press the point-key on the main 
part of the keyboard to get "," - pressing the ","-key is ignored. When using 
the komma on the numberblock, no sign is shown and the komma is ignored.
duplicate of bug 182229?
This is actually very annoying. How can this still be unfixed and even UNCONFIRMED?

Please FIX this asap.
This bug is still alive in Mozilla Version 1.5 and 1.7b on Linux (FC1) and Solaris! 
Duplicate of bug 159733 "the comma on the numeric keyboard doesn't work"

*** This bug has been marked as a duplicate of 108170 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.