Decimal separator ',' (comma) on german keyboard (on keypad/numpad) shows up as '|' (pipe)

RESOLVED FIXED

Status

RESOLVED FIXED
18 years ago
10 years ago

People

(Reporter: c, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Bug Flags:
blocking1.8b -
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
My system: SuSE 7.1 / KDE, german keyboard, fresh (english) Mozilla CVS build.

If I press the decimal separator in the numeric block of the keyboard (this is
supposed to be a comma on german keyboards) I get a vertical bar ('|') instead
(everywhere I can type text in Mozilla).

This is because GDK_KP_Separator is translated into '|' in nsGtkEventHandler.cpp, 
but should be ','.
(Reporter)

Updated

18 years ago
Keywords: patch, review

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1
1.1alpha is gone..

c@c07.de (Andreas M. "Clarence" Schneider) : 
You must request a review via mail. (if the patch isn't out of date)

Are you still there ?
Target Milestone: mozilla1.1alpha → ---

Comment 3

17 years ago
--> default owner
Assignee: hyatt → jaggernaut
Status: ASSIGNED → NEW

Comment 4

17 years ago
Is this still an issue, and if so, is the patch the appropriate fix. (Sorry 
for the fact that this has not moved anywhere).
*** Bug 205533 has been marked as a duplicate of this bug. ***
Summary: Decimal separator ',' on german keyboard shows up as '|' → Decimal separator ',' on german keyboard (on keypad) shows up as '|'
*** Bug 218283 has been marked as a duplicate of this bug. ***
Assignee: jag → blizzard
Component: XP Toolkit/Widgets → GFX: Gtk
QA Contact: jrgmorrison → ian
(Assignee)

Comment 7

15 years ago
Is the seperator on english keyboards a slash?

Comment 8

15 years ago
According to gtk2 source, 0xFFAC (KP_Separator) is supposed to produce ',',
while KP_Decimal is supposed to produce a '.'

KP_Separator is not present on English keyboard. But it is in some european
countries, instead of KP_Decimal, such as finnish (see bug
http://bugs.mandrakelinux.com/query.php?bug=376 )

The problem is present in both gtk1 and gtk2 version of mozilla (in
source/widget/src/gtk2/nsGtkKeyUtils.cpp for gtk2)
*** Bug 193560 has been marked as a duplicate of this bug. ***
*** Bug 159733 has been marked as a duplicate of this bug. ***
Summary: Decimal separator ',' on german keyboard (on keypad) shows up as '|' → Decimal separator ',' (comma) on german keyboard (on keypad/numpad) shows up as '|' (pipe)

Comment 11

15 years ago
Created attachment 160938 [details] [diff] [review]
Patch against GTK2 source tree

The problem still exists in current builds. This patch fixes the GTK2 source
tree in the same way, as the GTK1 patch does.

Comment 12

15 years ago
Comment on attachment 160938 [details] [diff] [review]
Patch against GTK2 source tree

It would be nice, if the old GTK1 patch could also get r/sr.
Attachment #160938 - Flags: superreview?(bryner)
Attachment #160938 - Flags: review?(blizzard)
(Assignee)

Updated

15 years ago
Attachment #160938 - Flags: review?(blizzard) → review+

Comment 13

14 years ago
Bug is still not resolved. It's annoying if you have to type a lot of numbers...

My system: Fedora core 1; linux 2.4.22-1.2115.nptlsmp; GUI: Gnome-german;
Mozilla 1.7-german,
Keyboard: german

Comment 14

14 years ago
This bug is still present, confirming with both Firefox 1.0 (Debian package
1.0-4) and Seamonkey 1.7.3 (Debian package 1.7.3-5). Is anything slated to fix
this? It really *is* annoying, especially for online banking.

Comment 15

14 years ago
C'mon dudes! This bug was opened _2001_ and a patch available immediatly and 
it's still not incorporated properly and still present in 2005! I can confirm 
that the same problem is present on swedish keyboards too. Feels awkward to DL 
the source and recompile to fix a _oneline_ bug. Good work on the rest 
nonetheless.. ;-)
hmm... the patch even has r+ already, what happened to sr+?
Is Bryner around to do superreviewing or should we ask s.o. else?
Flags: blocking1.8a6?
Flags: blocking-aviary1.1?
Attachment #56238 - Flags: superreview?(bryner)
Attachment #56238 - Flags: review?(blizzard)
Attachment #56238 - Attachment description: patch → gtk1 patch
too late for non-critical fixes. blocking-
Flags: blocking1.8a6? → blocking1.8a6-
Flags: blocking1.8b?
Flags: blocking1.8a6?
Flags: blocking1.8a6-
oops, somehow the 1.8a6- got overridden...
Flags: blocking1.8a6? → blocking1.8a6-

Comment 19

14 years ago
Confirming on Danish keyboard, with Ubuntu packages. And with official Firefox 
official binaries. 

Updated

14 years ago
Flags: blocking1.8b?
Flags: blocking1.8b-
Flags: blocking1.8a6-
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1-
May I ask _why_ blocking-aviary1.1 was denied? Firefox 1.1 is not scheduled
until June and there are patches, of which one already has r+ - so why not
implement it?
Attachment #160938 - Flags: superreview?(bryner) → superreview+
Attachment #56238 - Flags: superreview?(bryner) → superreview+
Comment on attachment 160938 [details] [diff] [review]
Patch against GTK2 source tree

low risk patch - just changes the character that's generated for
GDK_KP_Separator
Attachment #160938 - Flags: approval1.8b?
Attachment #56238 - Flags: review?(blizzard) → review+
Comment on attachment 160938 [details] [diff] [review]
Patch against GTK2 source tree

a=caillon for 1.8beta
Attachment #160938 - Flags: approval1.8b? → approval1.8b+
Comment on attachment 56238 [details] [diff] [review]
gtk1 patch

would be nice to have this too in 1.8b - the same patch for gtk2 is already
approved.
Attachment #56238 - Flags: approval1.8b?
gtk1:
Checking in widget/src/gtk/nsGtkEventHandler.cpp;
/cvsroot/mozilla/widget/src/gtk/nsGtkEventHandler.cpp,v  <--  nsGtkEventHandler.cpp
new revision: 1.189; previous revision: 1.188
done

gtk2:
Checking in widget/src/gtk2/nsGtkKeyUtils.cpp;
/cvsroot/mozilla/widget/src/gtk2/nsGtkKeyUtils.cpp,v  <--  nsGtkKeyUtils.cpp
new revision: 1.12; previous revision: 1.11
done

marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.