Scroll position resets after enabling/disabling mail filter

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: arnoudb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build ID: 2003021008/WinXP.

Scroll position resets after enabling/disabling mail filter.

Steps to reproduce:
1. Make sure you have enough filters so that the filter list is scrollable, or
resize the window till it does.
2. Now scroll all the way down and click the Enabled checkbox on one of the filters.

Result:
Scroll position is now reset, putting you back all the way on top of the list.

Expected behaviour:
Scroll position stays as-is.

Comment 1

16 years ago
This phenomenon is reproduced also by following build.

o Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312
    with Mac OS X 10.2.4
o Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
    with Win2000 (Japanese) SP3

Comment 2

16 years ago
If any item are selected, scrolled to the position which can show it.
Otherwise, scrolled up to top.
mass re-assign.
Assignee: naving → sspitzer

Comment 4

16 years ago
*** Bug 201935 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
Confirming this still exists on Seamonkey Trunk 2004111805 on Win ME.  

Changing Hardware & OS to ALL based on Comment 1
OS: Windows XP → All
Hardware: PC → All
Product: MailNews → Core

Comment 6

14 years ago
Confirming that this still happens under version 1.0 (20041206) of Thunderbird.

Comment 7

12 years ago
*** Bug 361976 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
See the similar symptom at bug 363411.
Assignee: sspitzer → nobody
Severity: normal → minor
QA Contact: laurel → filters

Comment 9

12 years ago
It looks like there's a whole group of unnecessary scrolling bugs involving filters.  I'm wondering how hard these are to fix that they've been around for years?  It sounds more like taking out code...

Updated

11 years ago
Duplicate of this bug: 408155
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 11

10 years ago
FWIW, I cannot reproduce this problem with current builds. https://bugzilla.mozilla.org/show_bug.cgi?id=363411 is still a problem, but this bug and the ones marked duplicates of this I cannot reproduce. Marking 'works for me'.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.