Bookmarks file and other preferences are deleted when disk is full

RESOLVED DUPLICATE of bug 190136

Status

()

Core
Preferences: Backend
--
critical
RESOLVED DUPLICATE of bug 190136
15 years ago
15 years ago

People

(Reporter: Martin Richartz, Assigned: Brian Nesse (gone))

Tracking

({dataloss})

Trunk
PowerPC
Mac OS X
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

When Mozilla can't write to disk because it's full (at session end or when
crashing) the bookmark file is truncated/deleted. This is more than *serious*. I
lost bookmarks I collected over years!

Reproducible: Always

Steps to Reproduce:
1. Make disk full. In OS X the startup disk is not user writable any more if
less than 5 % of its capacity are left (I may be wrong on the exact percentage)
2. Run Mozilla and add some bookmarks or change them otherwise
3. Quit Mozilla, and all your bookmarks are gone. Sometimes even all preferences

Actual Results:  
You end up with a virgin bookmark file (apparently created when Mozilla starts
and doesn't find a valid bookmark file)

Expected Results:  
It should not delete the old bookmark file and give a hint that it can't save
the modified bookmark file
should be fixed with bug 86501, doesn't this work on OS X or is this regressed ?
Keywords: dataloss

Comment 2

15 years ago
See bug 164244 comment #17 and maybe bug 186923.

Updated

15 years ago
Summary: bookmark file and other preferences are deleted when disk is full → Bookmarks file and other preferences are deleted when disk is full

Comment 3

15 years ago
Reassigning to Preferences: Backend.
Assignee: asa → bnesse
Component: Browser-General → Preferences: Backend
QA Contact: asa → sairuh

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 190136 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.