Need option key modifier to launch profile manager on Mac OS builds

VERIFIED FIXED

Status

VERIFIED FIXED
16 years ago
7 years ago

People

(Reporter: samir_bugzilla, Assigned: samir_bugzilla)

Tracking

({platform-parity, relnote})

Trunk
PowerPC
Mac OS X
platform-parity, relnote

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
Since we no longer ship the profile manager and profile migration ``argument
files'' with Mach-O builds we need a way to let users launch the profile manager
at startup.  Based on a discussion with Simon and JJ one recommended method is
to check for the option key modifier being held down at application launch time.

For netscape employees, see also bugscape 22266.
(Assignee)

Comment 1

16 years ago
Created attachment 114972 [details] [diff] [review]
Patch v1.0.

Thanks to Simon for the patch.
(Assignee)

Comment 2

16 years ago
Comment on attachment 114972 [details] [diff] [review]
Patch v1.0.

r=sgehani
Attachment #114972 - Flags: superreview?(jaggernaut)
Attachment #114972 - Flags: review+
http://bugscape.nscp.aoltw.net/show_bug.cgi?id=22266 for easier internal
linkification gratification.
Keywords: pp
Keywords: relnote

Comment 4

16 years ago
I'd like to get this in for 1.3 if possible. As soon as it's been fully reviewed
please request driver approval to land in 1.3. Thanks!

Comment 5

16 years ago
Comment on attachment 114972 [details] [diff] [review]
Patch v1.0.

sr=jag
Attachment #114972 - Flags: superreview?(jaggernaut)
Attachment #114972 - Flags: superreview+
Attachment #114972 - Flags: approval1.3?

Comment 6

16 years ago
Comment on attachment 114972 [details] [diff] [review]
Patch v1.0.

a=asa (on behalf of drivers) for checkin to 1.3
Attachment #114972 - Flags: approval1.3? → approval1.3+
(Assignee)

Comment 7

16 years ago
Robin, Jatin, please relnote this change for Netscape.

Asa, are you the right person to request a relnote change for mozilla 1.3?

Fix checked in for Simon.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 8

16 years ago
*** Bug 194316 has been marked as a duplicate of this bug. ***
vrfy'd fixed with 2003.02.24.03 comm trunk bits on 10.2.4.
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
Alt + doubleclick doesn't work. The only thing, which works, is to do Alt +
Click, if the icon is in the dock _and_ Mozilla is not running yet. If you do
Alt + Click, when Mozilla is running, Mozilla is hidden (which is the usual Mac
OS behaviour). This is very obfuscating --> I think this bug should be reopened.

Comment 11

15 years ago
> Alt + doubleclick doesn't work.

WFM with Mozilla 2004041708 on Mac OS 10.2.8. If you release the Alt key too
early it won't work. 

Comment 12

15 years ago
It definitely doesn't work here (Mozilla 1.7b, OS X 10.3.3). When I do Alt +
DblClick on the Mozilla Icon in the Finder Window, normal Mozilla starts up
_and_ the Finder Window disappeares.

I dought that this different behaviour is due to the fact that we have different
Mozilla versions, since the checkin for this bug was before 1.7b. Instead, there
might have been a change from 10.2.x to 10.3.x which causes the OS to catch the
Alt + DblClick-Event?

Comment 13

15 years ago
Ok - when pressing Option longer than the doubleclick, Profile Manager opens.
This is not obvious

But at the same time, the finder window disappears due to Option+DblClick. I
think this will obfuscate many users and it's not a good solution.

Updated

10 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.