Closed Bug 194219 Opened 22 years ago Closed 22 years ago

Closing all windows cancels active downloads without warning.

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 28385

People

(Reporter: niall, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210


If you start a long download then close all browser windows then the download is
cancelled without warning.  It would be nice to have a confirmation dialog
saying something like "You currently have active downloads, closing all browser
windows will cancel them.  Do you wish to continue?".  The dialog would probably
have a checkbox to prevent the browser asking again if that is what the user
preferred.

Reproducible: Always

Steps to Reproduce:
1. Start a long download
2. Close all windows
3. Restart browser
4. Open download manager

Actual Results:  
The download was cancelled.

Expected Results:  
Prompted me if I really wanted to exit as it would cancel active downloads.
Are you also closing the download manager window (in the middle of the
download)?  Or are you using a progress dialog?  Or are you using no progress
window of any sort?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

I agree this is a bug. When I start downloading something, the download manager
pops up, but I tend to close it stright away. As long as some mozilla window is
open the download continues, however the download stops if all mozilla windows
are closed. No matter in what order the mozilla browser window and download
manager are closed, there is no warning about the fact this will stop file
download. Either closing the download manager should cause downloads to stop
(with warning?)  or some other option
Dup of either bug 147254 or bug 181374
I should have mentioned in the initial bug report that I am not using Quick Launch

If you have enabled Quick Launch then the assumption is that downloads should
continue even though all browser windows have closed (this is not happening in
1.3.1b, hence bug 147254).

This bug addresses a different issue -- if you have disabled Quick Launch then
exiting the browser will cancel active downloads, I would just like a
confirmation dialog before this happens.

Boris - as per MrJeff's comments, it doesn't matter which order you close the
windows in.

Wesha - not sure if this is really a dupe of either of those as both seem to
involve Quick Launch functionality.

  
Of course there is a question here if the behaviour should differ depending on
whether Quick Launch is enabled.  There is also the possibililty that closing
the Quick Launch icon when there are active downloads should cause a similar
confirmation dialog as requested in this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 28385 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.