Alert user before file->exit if files are still downloading

RESOLVED WONTFIX

Status

SeaMonkey
Download & File Handling
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: gabriel, Unassigned)

Tracking

({dataloss, relnote})

Trunk
dataloss, relnote
Dependency tree / graph
Bug Flags:
blocking1.7b -
blocking1.7 -
blocking-seamonkey2.0 -
blocking-seamonkey2.0a1 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3] [UI])

(Reporter)

Description

17 years ago
Many times when using Netscape, I exit from the application, only to realise I
was still halfway thru downloading (save to disk) a file. This is extremely
infuriating. It would be wonderful if Mozilla warned the user 'You are still
downloading files, do you really want to quit ?' before exiting. Apologies if
this is a dup.

Comment 1

17 years ago
maybe a networking thing?  
Component: Browser-General → Networking

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
That's a cool idea. Right now, Mozilla keeps the download alive if you close the 
last window but quits the download if you choose quit from the file menu in a 
Mozilla window. It really should ask for permission to quit the download since 
they're probably not meant to be cancelled

Comment 3

17 years ago
udpating component owner.
Assignee: cbegle → gagan
QA Contact: asadotzler → tever

Comment 4

17 years ago
=> law
Assignee: gagan → law
Component: Networking → Browser-General
Target Milestone: M16

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

17 years ago
Target Milestone: M16 → Future

Comment 5

17 years ago
May depend on bug 44602.

Comment 6

17 years ago
Another file download nomination.  Problem is a PITA, need to see how hard it is
to come up with some acceptable fix.
Keywords: nsbeta1
Component: Browser-General → XP Apps
QA Contact: tever → sairuh

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+
Target Milestone: Future → mozilla0.9.1
as discussed in team meeting, moving all Nav+ team members nsbeta1+ P3 bugs from 
mozilla0.9.1 to mozilla0.9.2. 
Target Milestone: mozilla0.9.1 → mozilla0.9.2
nav triage: moving to m0.9.3. 
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 9

16 years ago
Matthew: proper UI/wording?  Should download windows just not be closed upon 
quitting?

Comment 10

16 years ago
--> me
Assignee: law → blake
Status: ASSIGNED → NEW
Blocks: 71806
Blocks: 78106
No longer blocks: 71806

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 11

16 years ago
> Matthew: proper UI/wording?

If you want to truly delight people:
+------------------------------------------------------+
|::::::::::::::::::::::::::::::::::::::::::::::::::::::|
+------------------------------------------------------+
|   .   If you quit now, 3 files which are being       | \ large
|  /!\  downloaded will not download completely. Are   | } system
|  """  you sure you want to quit?                     | / font
|                                                      |
|       Downloading will finish in about 17 minutes.   | } small system font
|                                                      |
|                         ( Cancel ) (( Quit Anyway )) |
+------------------------------------------------------+

Show this alert *before* any windows are closed -- if the user is resigned to 
spending another 17 minutes online, she may wish to continue browsing or 
whatever in her existing windows. And use separate strings on Windows, with 
`exit' in the place of `quit'.

> Should download windows just not be closed upon quitting?

Yes -- but that requires making the browser and the download manager separate 
executables. Otherwise you're not telling the truth about what `Quit'/`Exit' 
means, and not telling the truth is marginally worse than putting up an extra 
alert.

See also bug 65121 (though that bug doesn't apply to Mac OS, so it wouldn't 
make this bug obsolete).

Updated

16 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Updated

16 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 12

16 years ago
dataloss, critical severity
Severity: enhancement → critical
Keywords: dataloss

Comment 13

16 years ago
--> ben, he's doing download mgr stuff (or thinking about it)
Assignee: blakeross → ben
Status: ASSIGNED → NEW

Updated

16 years ago
Target Milestone: mozilla0.9.5 → ---
Could be part of download manager, but .1 because not immediately required. 
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1
spam: over to File Handling. i have not changed the assigned developer [or the
other fields for that matter], so if anyone realizes that a bug should have a
more appropriate owner, go ahead and change it. :)
Component: XP Apps → File Handling

Comment 16

16 years ago
*** Bug 104469 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: nsbeta1

Comment 17

15 years ago
So what happened with this, is is a part of download manager?
Whiteboard: [need info]

Comment 18

15 years ago
nsbeta1+ per Nav triage team, nav3, ->1.0
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [need info] → [need info][nav3]
Target Milestone: mozilla1.0.1 → mozilla1.0

Comment 19

15 years ago
Please update this bug with an [adt1] - [adt3] impact rating (or take it off the
list if it doesn't even rate adt3.)  Thanks!

Comment 20

15 years ago
converting nav3->adt3
Whiteboard: [need info][nav3] → [adt3]
-> blake
Assignee: ben → blaker
Status: ASSIGNED → NEW

Comment 22

15 years ago
This really isn't specific to download manager either.  --> law (I know you have
a lot on your plate, but so do I. Maybe I can get to this soon.)
Assignee: blaker → law

Comment 23

15 years ago
I happened to think about this again recently while working on something related.

Here's an idea: if we just add a function named tryToClose to the download
progress <window> (and in the download manager window?), then this will be
called at File->Quit time.  There, we can put up a dialog like the one mpt
suggests and cancel the quit if the user says to.

This might be complicated by download manager interactions (no progress dialogs,
download manager not open) but otherwise might provide a means to a simple fix.
 I won't get to it soon since I have [adt2] and [adt1] stuff.

Comment 24

15 years ago
Mass moving nsbeta1+/adt3 bugs assigned to Navigator team engineers out to
target milestone 1.0.1.  Please confine your attentions to driving down our list
of TM 1.0 bugs for beta.  Better to help, debug, or test one of them than fix
one of these.
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 25

15 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1-

Comment 26

15 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1+

Comment 27

15 years ago
This needs to be fixed quickly especially since the download manager is the
default. With the progress dialog, one can see them before quitting. But now,
the downloads are hidden and the download manager can be discarded at will. So
how does one know he can "safely" quit? First, he has to go in "Tools | Download
Manager" (no shortcut). Then he can go in "File | Quit". That's not what I would
call "user friendly"!!!!
I understand that there is still some important work to do for the final release
but for this, people are going to complain (actually, we already do :p) and even
more now that the download are not readily visible in the taskbar (or equivalent)

Because of bug 142310, I couldn't try but what will happen if one close the
download manager window then close the last navigator window?

Comment 28

15 years ago
Proposed relnote: If the user is downloading a file in the background with
Mozilla, and the user exits Mozilla from the File menu, the download will abort
without warning. 
Keywords: relnote

Comment 29

15 years ago
See also bug 147254, Download dies when last window is closed.  Changing summary
to differentiate from 147254.
Summary: Alert user before Mozilla exit if files are still downloading. → Alert user before file->exit if files are still downloading

Comment 30

15 years ago
*** Bug 155980 has been marked as a duplicate of this bug. ***
would it be possible to fix this for buffy?

this also affects embedded apps, such as chimera.
Blocks: 127253
Keywords: nsbeta1- → nsbeta1

Comment 32

15 years ago
Nav traige team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+

Updated

15 years ago
Blocks: 163954

Comment 33

15 years ago
*** Bug 159679 has been marked as a duplicate of this bug. ***

Comment 34

15 years ago
While I agree with the suggestion in comment #11 (I would have made a similar
one myself if it wasn't there), I must add that the confirmation dialog should
appear at all times, even if there are no downloads in progress.

A possible exception (but not really necessary), it is not required if _ONLY
ONE_ mozilla window is displayed.
re comment #34: no - confirmation should only be asked for if there is the 
danger of data loss. This bug is about a confirmation when downloads
are going on. Your suggestion does not belong in this bug, but 
bug 39057 (verified wontfix).
(Reporter)

Comment 36

15 years ago
This bug has been open for 2.5 years. Is any progress being made on it ?

Comment 37

15 years ago
This is related to bug 131500, which could be formulated as:
"Alert user before file->work offline if files are still downloading"
QA Contact: sairuh → petersen

Updated

15 years ago
Blocks: 157421
*** Bug 183757 has been marked as a duplicate of this bug. ***

Comment 39

15 years ago
Over to Jan.
Assignee: law → varga

Updated

14 years ago
Target Milestone: mozilla1.0.1 → mozilla1.4beta

Comment 40

14 years ago
*** Bug 174136 has been marked as a duplicate of this bug. ***

Comment 41

14 years ago
*** Bug 195863 has been marked as a duplicate of this bug. ***

Updated

14 years ago
No longer blocks: 157421
Flags: blocking1.4a?

Comment 42

14 years ago
About Comment #35, I'm sure we've all have downloaded files from low-bandwidth
servers that are very hard to restart downloads from. It's arguably a form of
data loss when data on your HD is rendered useless, as a partial doanload is. At
least let users choose whether to have the warning.

Updated

14 years ago
Flags: blocking1.4a? → blocking1.4a-

Updated

14 years ago
Whiteboard: [adt3] → [adt3] [UI]

Comment 43

14 years ago
*** Bug 95416 has been marked as a duplicate of this bug. ***

Comment 44

14 years ago
*** Bug 194219 has been marked as a duplicate of this bug. ***
from Bug 194219 :
------- Additional Comment #5 From Christian Biesinger  2003-04-19 15:24 -------

http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/content/globalOverlay.js#9

isn't it lovely, there is currently no way to fix this bug...


(but I may of course be missing something...)

Comment 46

14 years ago
Sure there is. Implement 'tryToClose' on those windows that handle downloads.

Comment 47

14 years ago
Hey guys, this bug is 3 years old, blocks 3 other bugs and has 38 people waiting
on it.

Why don't you fix it already?

Updated

14 years ago
Flags: blocking1.4b?
Flags: blocking1.4?
smfr: such windows don't necessarily exist, afaik, as you need not have progress
windows and can have the dl mgr window closed

Updated

14 years ago
Flags: blocking1.4b?
Flags: blocking1.4b-
Flags: blocking1.4?
Flags: blocking1.4-

Comment 49

14 years ago
Why don't downloads fork to a helper app?  Is it too much to maintain a bunch 
of lightweight, one-function download windows?

As for downloads that don't have their own windows, I suggest WONTFIX because 
people generally want network activity to halt when they close its associated 
window.

Updated

14 years ago
Depends on: 36776

Comment 50

14 years ago
Added dependency to the bug which requires computation of download status.

Ccing Bill Law (desktop integration and file download) from XP-Apps

Comment 51

14 years ago
Let me suggest one possible solution: as long as mozturbo is running, downloads
should continue downloading. This is similar to Kazaa where downloads continue
as long as application is alive in the launch bar (bottom right in Windows).

Comment 52

14 years ago
RE #51... It's a good thought, but unfortunately turbo mode is broken, Mozilla
exits completely and restarts, until this behaviour gets corrected it won't be
possible.
re #51: turbo only exists or makes sense for the windows port, and this is a
problem on all OS.

Comment 54

14 years ago
*** Bug 208411 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.4beta → mozilla1.5alpha

Comment 55

14 years ago
Ok, I suppose I need some clarification here.

I've read through the bug and it sounds like all that is necessary is that we
are able to query whether there there are one or more downloads currently in
progress.  If there are, then present something to the effect of the dialog
proposed in comment 11.  Is that right?

So why, then, is this dependent on bug 36776 (Show download progress in window
icon)?  That bug is caught up in colors and behaviors of icons.  All we really
need to know is, "are there any downloads in progress? Yes or no?"

Is there a neccesity to create a means to do this in a seperate bug?

Might I suggest that if there is a desire do deal with this problem in a more
complex way other than a simple warning dialog that a seperate bug be filed or
this bug will likely take another 3 years to be resolved.

Comment 56

14 years ago
I was to report as a bug, that when I restart Mozilla,
the download manager have cancelled my download,
rather than continue downloading where it was. Which
is what I expect it to do. But somehow, it seems way
much more complex than can be implemented for now.
I almost what to go see the code and see what should
be done for doing this. Afterall, this is supported
both by FTP and HTTP (1.1?) for quite a long time.

Comment 57

14 years ago
Well, actually, I guess it is best to simply pause all downloading files
before quiting Mozilla. That way, one have full bandwith when he restart
Mozilla, and still can resume download (which is impossible now because
they are cancelled).

Comment #11 is still usefull for dowloading files which are not restartable,
because the server don't support it. But for now, nothing shows that Mozilla
try to know a download is restartable. So for now, what seems to make sense
is just to pause all files before quitting.

Updated

14 years ago
Target Milestone: mozilla1.5alpha → mozilla1.5beta

Comment 58

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030815

Isn't this bug moot at this point, as Mozilla now exhibits the default behavior
of Netscape 4.x where downloads will continue to run and will complete
successfully even after the last browser window is closed (or until the user
cancels the download)?

Comment 59

14 years ago
See also bug 219758, same bug for Firebird.

Comment 60

14 years ago
Not moot. Still occurs in Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.5) Gecko/20030925.

Comment 61

14 years ago
*** Bug 225153 has been marked as a duplicate of this bug. ***

Comment 62

14 years ago
*** Bug 228581 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Flags: blocking1.7b?

Comment 63

13 years ago
Update to the person in charge of this issue:

- 52 users waiting for a fix
- Issue is 4 years old

Comment 64

13 years ago
I agree. This is a cryin' shame. What is getting in the way of development? It
seems to me that the TryToClose () routine is a fine solution. The UI is also
already sketched out. Is there some big ugly problem in the code? Could we just
mark it as blocking a release to get some attention? This thing has been moved
to future releases a ton of times. 
 

Comment 65

13 years ago
for anyone that wants/needs this they should migrate to firefox... 

from ben:
exit the app, we prompt first and ask if you want to cancel (#) downloads.
once we get cross session resume this won't be necessary. 

unless jan varga or someone has cycles to to this in the full suite it's
unlikely  to appear there...  guess we should mark this works for me in firefox,
or won't fix in seamonkey unless we can get someone to step up.
Flags: blocking1.7b? → blocking1.7b-

Comment 66

13 years ago
for anyone that wants/needs this they should migrate to firefox... 

from ben:
exit the app, we prompt first and ask if you want to cancel (#) downloads.
once we get cross session resume this won't be necessary. 

unless jan varga or someone has cycles to to this in the full suite it's
unlikely  to appear there...  guess we should mark this works for me in firefox,
or won't fix in seamonkey unless we can get someone to step up.
please do not abuse bugzilla as a firefox promotion forum. There are many people
who have reasons why to prefer the suite and want it fixed it the suite. If
somebody comes up with a patch it will get fixed - there is not reason to
WONTFIX this. 

Comment 68

13 years ago
I totally agree with Johann Petrak. This bug seems important enough to be
considered in the suite as well! 38 votes are here to confirm our opinion!!!

If you do not want to fix such a bug in the suite, then stop releasing Mozilla
Suite, things would be clearer and effort concentrated on one product!

I sincerly hoped this bug to be fixed in 1.7... :-(

Updated

13 years ago
Flags: blocking1.7?

Comment 69

13 years ago
the intent was not to promote firefox. the intent was just to a clearity about
where solutions to this problem can be found. if someone comes up with a good
patch for this to apply to the suite we would definitely take it.  

Comment 70

13 years ago
I know nothing about C or C++ programmation but what could prevent Mozilla to
check how many downloads are in progress and ask the user to confirm to quit if
this number is non zero?

If I understand (more or less) correctly, canQuitApplication() checks if Mozilla
can quit and is called by goQuitApplication() in
http://lxr.mozilla.org/mozilla/source/toolkit/content/globalOverlay.js#24

Moreover, numActiveDownloads seems to count how many downloads are in progress
in
http://lxr.mozilla.org/seamonkey/source/embedding/browser/powerplant/source/UDownloadDisplay.cpp#192

Could not canQuitApplication() check if numActiveDownloads == 0 ?

Please don't laugh, as I said: I know nothing about C++! I am just surprised
that this bug remains open for such a long time (4 years now).

Comment 71

13 years ago
not going to block the release on a feature that would require significant
changes to localizable strings. We're past under L10N freeze. 
Flags: blocking1.7?
Flags: blocking1.7-
Flags: blocking1.4b-
Flags: blocking1.4a-
Flags: blocking1.4-

Comment 72

13 years ago
LpSolit@netscape.net: in short, you're off by a module.
powerplant is a mac embedding system, it's not close to the download manager in 
question (which lives in 
<http://lxr.mozilla.org/source/xpfe/components/download-manager/src/nsDownloadMa
nager.cpp>).

chofmann: your comments were not constructive. if you want to provide clarity, 
provide an lxr url 
<http://lxr.mozilla.org/mozilla/source/toolkit/components/downloads/src/nsDownlo
adManager.cpp> or a keyword/search string.

for people playing along at home, the magic words are observer service and 
topics "quit-application" and "quit-application-requested". The last important 
piece is: 
http://lxr.mozilla.org/mozilla/source/toolkit/content/globalOverlay.js#30 which 
solves 
http://lxr.mozilla.org/mozilla/source/xpfe/global/resources/content/globalOverla
y.js#9
fixing this requires bug 238391 to be fixed

bug 36776 seems unrelated, removing from dependency field.
Depends on: 238391
No longer depends on: 36776

Comment 74

13 years ago
*** Bug 251884 has been marked as a duplicate of this bug. ***
*** Bug 315145 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Duplicate of this bug: 163954

Comment 77

10 years ago
This bug has been resolved (at least in Mozilla).  It now prompts before exiting.  Shouldn't someone close this thread?

Comment 78

10 years ago
(In reply to comment #77)
> This bug has been resolved (at least in Mozilla).  It now prompts before
> exiting.  Shouldn't someone close this thread?

The prompting is great, but it would be really nice to have the following options:

<current prompt text>

[Yes - Shutdown everything] [No - Show Download Manager, Close Browser] [Cancel - Leave Browser Open]

Thanks for considering this.

Comment 79

10 years ago
Indeed it has already been resolved.  This thread will be closed when someone who can sees it.
It's resolved in Firefox but not in SeaMonkey, does somebody know what Firefox bug fixed it?

Comment 81

10 years ago
The bug that was fixed in Firefox was 219758, so I think Product should be changed to Mozilla Application Suite.

Comment 82

10 years ago
Before I close this, which patch FIXED this in SeaMonkey?  Or should I
just WFM it as having been FIXED elsewhere?
Component: File Handling → Download Manager
Product: Core → Mozilla Application Suite
Target Milestone: mozilla1.5beta → ---

Comment 83

10 years ago
(In reply to comment #82)
> Before I close this, which patch FIXED this in SeaMonkey?  Or should I
> just WFM it as having been FIXED elsewhere?

I didn't know it was fixed in SeaMonkey, I was just saying that someone should do what you have just done (change the Product to Mozilla Application Suite) :-)

Updated

10 years ago
Flags: blocking-seamonkey2.0a1?

Updated

9 years ago
Assignee: Jan.Varga → nobody
Status: ASSIGNED → NEW
QA Contact: chrispetersen → download-manager
Priority: P3 → --

Comment 84

9 years ago
As far as I can see this is not fixed on SeaMonkey trunk though that will probably change when we switch to toolkit's download manager (as I think that has this protection built in) - Callek will need to advise on it.

Comment 85

9 years ago
Pushing out to 2.0.
Flags: blocking-seamonkey2?
Flags: blocking-seamonkey2.0a1?
Flags: blocking-seamonkey2.0a1-

Comment 86

8 years ago
Firefox is not doing this any more, presumably because the current download manager implementation can resume downloads after restarting.
Also because of the same, I don't think we need to do this for SeaMonkey with this implementation, so marking WONTFIX.
Severity: critical → normal
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Duplicate of this bug: 147254
Is it not the case, that the resume feature can only work with servers that support to resume a download? Also, even if a download can be resumed, a user might not be aware that it is still going on and a warning would be extremely useful.
Firefox warns and nags in all kinds of situations (e.g. when more than one tab is being closed by default) that are much less useful, it is hard to understand why it should not warn in this case.

Comment 89

8 years ago
The assumption that all webservers are able to support resume is invalid. Many downloads rely on the existence of sessions (wiped on FF exit), or are served by application servers that don't support HTTP ranges.

Comment 90

8 years ago
Not blocking 2.0 on this
Flags: blocking-seamonkey2? → blocking-seamonkey2-
You need to log in before you can comment on or make changes to this bug.