Closed Bug 194325 Opened 22 years ago Closed 9 years ago

telnet: URLs for Linux

Categories

(Core :: Networking, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: benc, Unassigned)

References

()

Details

Originally in bug 33282, this is a depends on that bug, which is no a much more
general discussion about getting external helper apps schemes to work in Linux.

There are probably a lot of aspects of telnet: URL security in that bug that
need to be dug out at some point in the future.
Depends on: 33282
ben - i have no idea what this bug is suppose to be for as it is written up.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → INVALID
No longer depends on: 33282
EXPECTED BEHAVIOR:
clicking on the URL would bring up a telnet session of some kind.

OBSERVED BEHAVIOR:
clicking on the URL returns "telnet is not a registered protocol."
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
and, why isn't this a dup of 33282?
Depends on: 33282
The security issues are essentially the same as launching a mime helper app. You
might look at bug 125505 which has a partial approach to exiting the mozilla
environment safely.
1- to catch dupes
2- because it is a depends.
3- because if I have to test areas that are not apparently the same, it is
easier to have each behavior described in a separate bug. That allows people to
focus on implementing the scheme->application mapping in that bug, and keep the
telnet-only drift in this bug.
wontfix.
Status: REOPENED → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → WONTFIX
Doug: why is this won't fix, if it is a depends on a bug that is assigned?
Reopening.  This is the bug for implementing a proper helper script or whatever
is needed for telnet; see last comments on bug 33282
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Moz 1.6 is out and still no way for a normal user (non programmer) to enable
telnet:// links.  

The workaround is to use mozex

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Thanks
Blocks: 37637
The workaround does not work if you are trying to deploy firefox to multiple PCs
and users automatically. Will this ever "just work" on a Linux box?
(In reply to comment #10)
> The workaround does not work if you are trying to deploy firefox to multiple
> PCs
> and users automatically. Will this ever "just work" on a Linux box?
> 

This still doesn't work on Firefox 1.5. Is there any activity on this bug?
mass reassigning to nobody.
Assignee: dougt → nobody
Status: REOPENED → NEW
Status: NEW → RESOLVED
Closed: 22 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.