Wish list of URL schemes and protocol handlers

RESOLVED FIXED

Status

()

Core
Networking
--
enhancement
RESOLVED FIXED
19 years ago
3 years ago

People

(Reporter: Mathieu Gervais, Unassigned)

Tracking

({helpwanted, meta})

Trunk
helpwanted, meta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (Win98; I)
BuildID:    not relevant

A not so important but cool feature would be to have support for sip: and tel: 
url used in VoIP telephony. Like telnet: url, it could launch the correct 
application. Currently no browser supports sip: urls

Reproducible: Always
Steps to Reproduce:
N/A - RFE

Actual Results:  N/A - RFE

Expected Results:  N/A - RFE

See http://www.cs.columbia.edu/~hgs/sip/ for information about the session 
initiation protocol. The RFC @ http://www.ietf.org/rfc/rfc2543.txt documents the 
sip URI scheme.

More information and links can be provided on demand.

I guess it's not that hard to implement, so given minimal directions, and based 
on the telnet: urls, I could implement it, if it's something you consider 
worthwhile.

Thanks

Comment 1

19 years ago
modified summary to add RFE.
ftp://ftp.isi.edu/in-notes/iana/assignments/url-schemes
sip is not on the list.
tel is.
If we are looking for protocols to add:
rtsp:// [it's on the list, and realplayer g2 or so probably needs to be able to 
hook in to be launched]
ldap://
irc://nick:pass@server/#channel#channel... [chatzilla or otherwise]
pnm:// [ref: http://www.webcs.com/webcsdocs/docs3/realaudio.html] -- 
RealPlayer5 and below.
ULP://
H.323://
fcp:// First Class really does have urls like this online.
Port/protocol tables:
http://www.chebucto.ns.ca/~rakerman/port-table.html
http://www.isi.edu/in-notes/iana/assignments/port-numbers

If we're just adding protocols:
rcp             469/udp    Radio Control Protocol
tv [people always joke about this, but i have a tv viewer app, and i probably 
could write the protocol association for windows, and a shell script for linux 
would be no harder (if I had an app to do it)]
--
Maybe necko just needs to ask plugins what protocols they support and query the 
os for apps registered for other protocols [refer to Netscape4 win32's 
approach?]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Support for sip:, tel: URLs → RFE: Support for protocols (rfc specified) tel: and (unspecified, rfc or not) sip:

Comment 2

19 years ago
->helpwanted
Assignee: gagan → nobody
Keywords: helpwanted
(Reporter)

Comment 3

19 years ago
The sip: URL scheme is now added to the official url schemes list maintained by  
IANA mentionned in earlier comments.

I was looking at the source via the web tool to try to evaluate the possibility 
of doing a quick hack to support sip: like telnet: is supported, i.e nothing 
fancy, just spawning an application. I wasnn't able to find the actual parsing 
of the telnet: protocol URL with LXR : 
http://lxr.mozilla.org/seamonkey/search?string=telnet

Where is the actual source code that does the parsing? Where is 
the define TELNET_TYPE_URL  actually used?
Summary: RFE: Support for protocols (rfc specified) tel: and (unspecified, rfc or not) sip: → RFE: Support for protocols (rfc specified) tel: and sip:

Comment 4

18 years ago
Given that it's unlikely Mozilla will support tel: or sip: natively, this is a
duplicate of bug 68406, "[RFE]W3C CUAP: Allow registration of new URI schemes"

Updated

17 years ago
QA Contact: tever → benc

Comment 5

17 years ago
mass move, v2.
qa to me.

Comment 6

17 years ago
since the bug morphed from the summary, I've converted into the wish list.
Keywords: meta
Summary: RFE: Support for protocols (rfc specified) tel: and sip: → [meta] [RFE] Wish list of URL schemes and protocol handlers

Comment 7

17 years ago
Some RFCs have recently been published defining URN schemes for bibliographic
references:

http://www.faqs.org/rfcs/rfc3187.html
RFC for ISBN URNs

http://www.faqs.org/rfcs/rfc3188.html
RFC for National Bibliography Number URNs

It would be neat if Mozilla had some way to support them, like by translating
them into query URLs to a site where you could look up information on books --
if it's something like amazon.com, it could even be a revenue source for the
Mozilla project if it had a referral ID embedded.

The ideal, of course, would be for there to be a configurable setting in Mozilla
to allow various URI / URL / URN schemes to be mapped at the user's option to
either a query URL (with the content segments of the URI inserted at
configurable places), a launching of a helper application, etc.  For instance,
somebody might want to have URNs like "urn:isbn:1-2345-67890" translated to
"http://www.somesite.example/cgi-bin/isbn.pl?search=1-2345-67890".

This stuff is pretty minor in terms of actual likely use by normal Web users,
but it's the sort of thing that would help give Mozilla a reputation within the
computer geek community of being at the leading edge in supporting standards
regarding information structure (as opposed to eye candy).

(The title of this bug really ought to use "URI" instead of "URL", as this
encompasses URNs as well.)

Comment 8

17 years ago
doesn't protozilla support that?

Comment 9

17 years ago
I assume (but haven't seen) URN: bugs exist.

If not, lets create one and talk there.

Updated

16 years ago
Depends on: 6115

Updated

16 years ago
Depends on: 82776

Updated

16 years ago
No longer depends on: 82776

Updated

16 years ago
Depends on: 142557

Updated

16 years ago
Depends on: 142559

Updated

16 years ago
Depends on: 142790

Updated

16 years ago
Depends on: 66675

Updated

16 years ago
Depends on: 44317

Updated

16 years ago
Depends on: 85879

Updated

16 years ago
Summary: [meta] [RFE] Wish list of URL schemes and protocol handlers → Wish list of URL schemes and protocol handlers

Updated

14 years ago
Depends on: 144766

Updated

14 years ago
Depends on: 194325

Updated

14 years ago
Depends on: 200509

Updated

14 years ago
Depends on: 202715

Updated

14 years ago
Depends on: 243055

Comment 10

13 years ago
benc@meern.net, I and another user have done as you suggested.  See Bug 302951,
Bug 269917, Bug 302950, and Bug 302947.
This isn't on anyone's work list and realistically is an abandoned idea. I will close as wontfix - if someone has a patch or is actively going to work on it please reopen. (but please, only then.)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
Resolution: WONTFIX → FIXED
You need to log in before you can comment on or make changes to this bug.