deCOMification gfx , widget, layout dll

RESOLVED INCOMPLETE

Status

()

Core
Layout
P2
normal
RESOLVED INCOMPLETE
15 years ago
4 years ago

People

(Reporter: Alec Flett, Unassigned)

Tracking

(Blocks: 1 bug, {footprint})

Trunk
Future
footprint
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
As suggested by roc, we should continue our merging to encourage
deCOMification.. we'll merge these two DLLs in.. this should also allow us to
shrink the size of the linked-against gkgfx.dll. I think the only thing
remaining after this merge will be nsRect...

(in fact the merging of the view dll already allows us to move nsColorNames and
nsRegion out of gkgfx.dll into gklayout.dll)
(Reporter)

Updated

15 years ago
Status: NEW → ASSIGNED
Keywords: footprint
Priority: -- → P2
Target Milestone: --- → mozilla1.4alpha
Alec, are you going to do this anytime soon?

Updated

15 years ago
Summary: merge gfx and widget component DLLs into the layout dll → [minimo] merge gfx and widget component DLLs into the layout dll
(Reporter)

Updated

15 years ago
Target Milestone: mozilla1.4alpha → mozilla1.5alpha

Updated

14 years ago
Blocks: 213938

Comment 2

14 years ago
dougt is going to take this one
Assignee: alecf → dougt
Status: ASSIGNED → NEW

Comment 3

14 years ago
This is done.  minimo does merge all but NSS, NSPR, JS, and XPCOM into the
default test application.  215757 is tracking this further potential footprint
reduction.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

14 years ago
maybe we need to take off [minimo] - the goal here is to do this in the
non-static build, so that deCOMification can happen. if we just do it in the
static build, then we can't deCOMify in the default build.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: [minimo] merge gfx and widget component DLLs into the layout dll → merge gfx and widget component DLLs into the layout dll

Comment 5

14 years ago
I see.  The summary threw me off.  
Assignee: dougt → alecf
Status: REOPENED → NEW
Summary: merge gfx and widget component DLLs into the layout dll → deCOMification gfx , widget, layout dll
Well, deCOMtamination involves several things and some of them can be done
across library boundaries. But some changes require this merge.
*** Bug 199223 has been marked as a duplicate of this bug. ***
Blocks: 230605
Alec, would you be able to do this anytime in the forseeable future?

Updated

13 years ago
OS: Windows 2000 → All
Hardware: PC → All
QA Contact: ian → layout

Updated

8 years ago
Blocks: 105431
Does it make sense for this bug to be open still?  And assigned to Alec?
(Reporter)

Comment 10

8 years ago
hah no. Please close and/or reassign...
Closing as INCOMPLETE; I don't think we need a second meta-bug for deCOM.
Assignee: alecf → nobody
Status: NEW → RESOLVED
Last Resolved: 14 years ago8 years ago
Resolution: --- → INCOMPLETE
Target Milestone: mozilla1.5alpha → Future
You need to log in before you can comment on or make changes to this bug.