Closed Bug 19449 Opened 21 years ago Closed 20 years ago

Rember password feature prevents form submission

Categories

(Core :: DOM: Core & HTML, defect, P3, major)

PowerPC
Mac System 9.x
defect

Tracking

()

VERIFIED DUPLICATE of bug 32783

People

(Reporter: jason, Assigned: pollmann)

References

()

Details

(Keywords: platform-parity, Whiteboard: [nsbeta2+] - bug updated w/info;investigating PSM-ckritzer 06.02;)

Running M11 on Redhat 6.0, glibc2.1, kernel 2.2.13.

This report assumes that (1) you already have an account at Netflix.com and (2)
you have already enabled the mozilla Remember Password feature.

Go to www.netflix.com.
Click on the 'My Account' link in upper right corner.
Click on the 'Sign In' link in the upper right.
Enter your username and password into the right text boxes.
 Press the 'Continue' button.

Mozilla will ask if you'd like to save your Username and Password for this form.
Press the 'Cancel' button.
Mozilla will ask if you'd like to remember this decision for this form. You can
press either 'OK' or 'Cancel' (Should be 'Yes' or 'No').
Press the 'OK' button. The dialog disappears, but the form is not submitted to
the server for processing.

WIth the dialog box now gone, you can try to press the 'Continue' button on the
HTML form, but nothing happens.

This is fairly repeatable...but the Remember Password feature seems a wee bit
flaky in general.

-jason
Assignee: karnaze → pollmann
Reassigning to Eric.
Status: NEW → ASSIGNED
Target Milestone: M14
Steve, have you heard of this?
This behavior is not present in M11 (Build ID: 1999111520) for WinNT4 sp5.
It correctly (well, discounting the cruddy dialog terminology) continues and
submits the form.
Yeah, it seems fairly broken-ish on the linux port in M11. Lots of general
flakiness that made it really awkard to try and use. Once it got in your way,
there was no way to get around it though.
kennedyh@engin.umich.edu - hey Hugh, what's up?  :)
The dialogs being OK/Cancel instead of YES/NO is a known problem and is already
reported in a bug assigned to davidm.  Also the double dialog "would you like to
save" and "remember this decision" should be on a single dialog.  That is also a
reported but and is also assigned to davidm.
QA Contact update.
I was able to log into netflix successfully using this night's build.  I
answered "No" to the "would you like to save your login for this page" question.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Eric, I'm reopening this bug because I keep getting a "The connection was
refused when attempting to contact www.netflix.com." error message on the
2000-03-01-13 MacOS9 commercial build.  It happens regardless of clicking Yes or
No to the "would you like to save your login for this page" question...
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Bummer, is this also present on Win and Linux commercial build?  sounds like it
might be an https problem.
M14 is closed.  This is med/major problem, so moving to M17.
Status: REOPENED → ASSIGNED
Target Milestone: M14 → M17
nominating for nsbeta2 based on:
 - severity
 - visibility
 - major feature broken
Keywords: nsbeta2
ckritzer, PDT need to know if this happens with last good build please.
Whiteboard: [NEED INFO]
Tested on:
 - MacOS9 2000-04-27-08-M16 Commercial Build - bug still exists
 - Linux6 2000-04-27-09-M16 Commercial Build - works correctly
 - Win98 2000-04-27-09-M16 Mozilla Build     - works correctly
Whiteboard: [NEED INFO] → [NEED INFO] - bug updated w/info
Keywords: pp
OS: Linux → Mac System 9.0
Hardware: PC → Macintosh
See bug 32783
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [NEED INFO] - bug updated w/info → [nsbeta2+] - bug updated w/info
This works fine when logging in using the Standard Server on the Mac (link on 
the bottom of the login page.)  Since PSM is required for the secure server, I'm 
marking this a dup of the other PSM required for secure form submit on Mac bug.

*** This bug has been marked as a duplicate of 32783 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
Whiteboard: [nsbeta2+] - bug updated w/info → [nsbeta2+] - bug updated w/info;investigating PSM-ckritzer 06.02;
Marking VERIFIED FIXED on:
- MacOS9 2000-07-12-15-M17 Commercial
- Linux6 2000-07-12-21-M17 Commercial
- Win98  2000-07-12-21-M17 Commercial
Status: RESOLVED → VERIFIED
OS: Mac System 9.x
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.