mailto: link click -> "mailto is not a registered protocol"

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
--
major
RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: Joshua Schulenberg, Unassigned)

Tracking

Bug Flags:
blocking1.6 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

163.52 KB, application/octet-stream
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

After upgrading to Mozilla 1.3b and clicking on a mailto: link, I get "mailto is
not a registered protocol" error. Downgrading to Mozilla 1.2 seems to correct
this problem.


Reproducible: Always

Steps to Reproduce:
1. Download Mozilla 1.3b for RedHat 8 RPMs (xft)
2. Click on a mailto: link
3. Problem occurs

Actual Results:  
Same issue. I also have tried Mozilla with a clean configuration.


Expected Results:  
Loaded Mozilla Mail.

Comment 1

15 years ago
nuking flag, this is not a security related bug and it's not going to be noticed
until the flag's removed.

are you sure you installed mail?
Group: security

Comment 2

15 years ago
I get the exact same error under the exact same circumstances.  Trying to load
Evolution.

Comment 3

15 years ago
->networking.

The error occurs in linux when you installed w/o mailnews. I don't use rpm's on
linux, so you need to look at what you did and whether mailnews was added.
probably checking the window menu will tell you.
Assignee: asa → dougt
Component: Browser-General → Networking
QA Contact: asa → benc

Comment 4

15 years ago
I've got the same problem running Debian Unstable (Mozilla 1.3) 
 
Installed all mozilla related components including the browser, mail, news, 
etc. Normally, clicking on a mailto: link brings up new message window from 
mailnews. No problem. Add the following lines to prefs.js to change to an 
external email client: 
 
user_pref("network.protocols.useSystemDefaults", true); 
user_pref("network.protocol-handler.external.mailto", true); 
user_pref("applications.mailto", "/usr/bin/evolution"); 
user_pref("applications.mailto.host", "%url%"); 
 
Restart Mozilla and click on mailto: link and get error: 
 
"mailto is not a registered protocol" 
 
The only two files that call the NS_ERROR_UNKNOWN_PROTOCOL error 
are: 
 
./netwerk/base/src/nsIOService.cpp 
./uriloader/exthandler/nsExternalProtocolHandler.cpp 
 
Hope this helps. 

Comment 5

15 years ago
Anthony:

If you don't install mailnews, then the browser will try to use an external,
default mailer. This works on mac and windows, but not in Linux.

If you try to set this configuration by hand, that is actually a separate
feature.   Since this is actually a different feature at work, please move that
problem to a new bug, and put a comment to it in this bug.

In both cases, you probably end up being faced with bug 56478.

Joshua, can you confirm that you didn't install mailnews (browser-only) when you
installed? You can look in the Window menu.
Summary: When attempting to click on a mailto: link, I get "mailto is not a registered protocol" → mailto: link click -> "mailto is not a registered protocol"

Comment 6

15 years ago
I don't think this was in 1.4RC1 but it has appeared in the 2003061611 nightly

Comment 7

15 years ago
This appears to have broken in AIX starting with with the 1.5 releases.
Cursoring over a mailto link shows ':' in the status window.

Comment 8

15 years ago
I am seeing this on both XP home and Pro running Build 2003061704.  It is very
annoying.  Happens in frames and no frames.  I too get the ':' in the status bar.

One difference is that I get "is not a registered protocol" in the pop-up (no
mailto: ...)

I have Mozilla as my default mail, browser, news, ...

Comment 9

15 years ago
David, Bob, this sounds like a different problem.

Why don't you compare problems (see if there is the same) and file a new bug (or
two) as needed.

In the case described here, the status should show "mailto:" URLs correctly, it
is the click-event that fails.

It sounds like you are seeing some new, underlying parser error. Please include
a publicly available URL.

Comment 10

15 years ago
Version: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030613

Yeah, this doesn't work for me, either.  Same problem on both A links and LINK
tags.  The URL shows itself as ":" when you hover over it.  This is a pretty
serious bug.

Somebody confirm the bug.  I don't have the power to do so.

Comment 11

15 years ago
reporters, can you attach the components/compreg.dat to this bug?

blizzard, you doing any special with mail/news in the RPM?  Could it be that we
are missing the component entries for these things?
No, there's nothing strange in the rpms.

Comment 13

15 years ago
Created attachment 127399 [details]
compreg.dat for SineSwiper

Attached.  Running Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a)
Gecko/20030613

Comment 14

15 years ago
how are you launching the mozilla?  

Comment 15

15 years ago
Uhhhh...double-clicking on the icon that sez "Mozilla".  You're going to have 
to be a little bit more specific :)

Comment 16

15 years ago
i get the same "is not a registered protocol" popup ... but i'm seeing it on a
mozilla on macOS X.  and on only one of two macintoshes on which i have mozilla
installed (this one running 1.5a 2003061308 and not the one running 1.4
20030624).  i saw a request for an attachment of compreg.dat, but i see no such
thing in my macOS mozilla prefs ...

Comment 17

15 years ago
another point of information to go with my previous post.  i noticed that the
version that had the bug for me on macOS was 1.5a, so i went back and installed
1.4, and the problem went away.  so perhaps the problem is not with any prefs or
other saved configuration information.

Comment 18

15 years ago
There are too many problem descriptions here.

If you are having a problem on a platform other than linux, you need to file a bug.

Joshua, doug's suggestion makes the most sense, that you have found a possible
problem w/ compreg.dat between the RPM releases of different versions.

Is this still a problem you see or can reproduce? 

Comment 19

15 years ago
> There are too many problem descriptions here.

There is no such thing as "too many problem descriptions".  In fact, most people
aren't descriptive enough.
 
> If you are having a problem on a platform other than linux, you need to file a 
> bug.

Filing another bug for the same problem is counterproductive and will probably
be marked as a dupe.  On the OS field, there is a option marked "All" where you
can specific that the bug occurs on ALL operating systems.  Since this bug
occurs on Windows, Linux, and MacOS, I think that's a good idea.

Comment 20

15 years ago
I'm having the problem on Mozilla 1.5 running on Windows 2000. I installed the
brower and Mozilla mail together. In the preference settings, I have checked
"Use Mozilla Mail as the default mail application," but apparently, the code
that works the magic when you check this box is broken.<p>
  This bug apparently occurs regardless of the OS platform. Won't you please
change the bug's OS field to "All"?

Comment 21

15 years ago
Brendan: how do you know these are all the same problem until they are fully
analyzed? You can't. And you can't effectively help several people with
potentially several different problem in a single bug.

Also, this problem is reported rarely enough that this is not happening to
everyone, so the root cause is going to take some digging to find.

It is much easier to isolate each person's problem, then dupe it back to the
original bug once you know it is a correct duplicate.

You can't un-dupe either, so pre-mature linking of bugs makes reading bugs very
messy. Getting a correct problem description for each bug is the first priority
of triage.

There is also a pretty big backlog of networking issues that need to be
analyzed. keeping bug reports short and focused makes it easier for people to go
back and help out here and there. If you have several possibly different problem
wadded up in a single bug, I end up spending my Saturday mornings unthreading
the bug rather than analyzing the problems.

Updated

14 years ago
Flags: blocking1.6?

Updated

14 years ago
Flags: blocking1.6? → blocking1.6-

Comment 22

14 years ago
This problem is no longer occuring for me on:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

Updated

14 years ago
Assignee: dougt → file-handling
Component: Networking → File Handling
QA Contact: benc → ian

Comment 23

14 years ago
*** Bug 258753 has been marked as a duplicate of this bug. ***

Comment 24

10 years ago
It seems Firefox 3 on Linux handles mailto links properly.
Assignee: file-handling → nobody
QA Contact: ian → file-handling

Comment 25

7 years ago
The bug should be closed, as Firefox 3 is now too outdated.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.