Closed Bug 56478 Opened 21 years ago Closed 15 years ago

mailto: link should launch OS mail client when installed w/o Mail/News

Categories

(Core :: Networking, defect, P3)

All
Linux
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: dan, Unassigned)

References

()

Details

(Keywords: relnote)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001010
BuildID:    2000101014

If you click on a mailto: link in mozilla that has been installed with out the
mail/news component, it will not dring up the defualt mail client to compose the
message.

Reproducible: Always
Steps to Reproduce:
Click on the mailto: link in the page using mozilla that has been installed with
out hte mail/news component.  This does not bring up the default mail client as
it should.

Actual Results:  This does not bring up the default mail client as it should.


Expected Results:  The default mail client (if it ewxists) should be invoked to
compose the message.
this is a duplicate f bug 11459 -mailto: can launch external mail app, or launch
a url

*** This bug has been marked as a duplicate of 11459 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Verified as duplicate of bug 11459
Status: RESOLVED → VERIFIED
reopening bug since I don't think this is actually a duplicate of #11459.  My
understanding is that bug #11459 is for having a separate helper app for mailto
links to mail vs newsgroups.  If everyone disagrees with me, could someone
please copy over the settings/cc list/assigned to/etc. from this bug to #11459?

This bug is also reported by Jacob Arnold at
http://www.macintouch.com/netscape6.html
Status: VERIFIED → UNCONFIRMED
Keywords: nsmac2
OS: Windows 98 → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Target Milestone: --- → mozilla0.9
Actually, this bug is basically the same as #11459.  It is about Mozilla not
using an external email program (what ever is the OS default) to send mail when
it is installed withou the mail/news options.
The test link that I provided no longer exists.
confirming bug and reassigning to mscott

This bug is also reported by Steve Linke at
http://www.macintouch.com/netscape6.html
Assignee: asa → mscott
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug is also reported by John Groseclose at
http://www.macintouch.com/netscape6.html
changing milestone to unknown.  It will get changed back when we figure out what
milestone to put this bug in.
Target Milestone: mozilla0.9 → ---
Also, under Linux at least, right-clicking and choosing "copy link location"
doesn't work if mail/news isn't installed. This seems related-but-separate --
I've filed it as bug 68310.
funny thing that 'gopher://any.uri' starts the right external program. where 
lies the difference ?
*** Bug 70923 has been marked as a duplicate of this bug. ***
i would think this bug is fixed on some platforms.
Depends on: 11459
Keywords: verifyme
->installer, + relnote.

The bug is a duplicate, the problem is an installer problem, that should be
release noted.
Assignee: mscott → ssu
Component: Browser-General → Installer
Keywords: relnote
QA Contact: doronr → gemal
sean: is this really installer? Isn't it up to the browser to just "say no" if 
mozilla mail isn't installed?
people could be using the zip file to install.
I'm at a loss as to why benc assigned this as an installer bug?

This actually works on Win32. If mail isn't installed we launch your default
mail application when you click on mailto and news urls from the browser. The
hooks are there for Mac already. I just haven't had time & knowledge yet to hook
up the Mac code to kick out urls we don't know how to handle to the OS.
This is definitely not an installer issue, but I'm not sure if this falls under 
mail or not.  Reassigning to mscott since he looks like he got it working under 
win32, but not all platforms yet.
Assignee: ssu → mscott
If we are not supporting mailto -> default OS mailto: handler, then it's an 
installer bug (b/c only the installer exposes it.

If we are supporting it, it needs a relnote. 

mscott: 
If we are going to fix this, I will take QA of this bug under "Networking" as 
part of my URL testing.
Summary: Clicking on a mailto: link doens't bring up a mail client if mozilla is installed without Mail/News → Clicking on a mailto: link doesn't bring up a mail client if mozilla is installed without Mail/News
I hope this may help some people:

If you want to use another mail client or news client then do not install
Mozilla's mail/news component. This way 'mailto:' and 'news:' URLs are
handled by the OS default program, otherwise Mozilla will ALWAYS use its own
mail/news client.
Unfortunately I don't know a way to deactivate or deinstall the mail/news
component after installation. This also applies when you 'install' Mozilla
through the non-installer ZIP archive.
So deinstall/remove Mozilla and reinstall only the wanted components with the
installer version.

Any help about deactivating/deinstalling a component after installation is
greatly appreciated.
QA Contact: gemal → gbush
You speak of "defaukt OS mailer", which is a notion existing only on windows or
MacOS. Or do the Unix versions use a specific environment variable ? (X-MAILER
or MAILER or something else ?)
For UNIX? I don't know. Run sendmail. :)
sendmail being an MTA, not an MUA that won't solve the bug.
The real problem is knowing how mailto: is handled. Its the same problem as
telnet: URLs. (Ironically, UNIX is where all this came from...)

RE: sendmail, mailto does not need a full UA, just an UA interface to an MTA.
Sendmail does this if run from the line command.

What about bz's mailcap | mime.type additions. Does this help our situation?
No.  Mailcap does not do protocols, just MIME types.

> mailto does not need a full UA

Sure it does.  It needs a place to type the message.  While sendmail does sorta
provide this if you make it read from stdin, that is just not a good way to go. 
:)

And lots of things use qmail instead of sendmail, btw.
here is how Nethack handles this:

/* #define NO_MAILREADER */     /* have mail daemon just tell player of mail */
 
#ifdef  MAIL
# if defined(BSD) || defined(ULTRIX)
#  ifdef AMS
#define AMS_MAILBOX     "/Mailbox"
#  else
#define DEF_MAILREADER  "/usr/ucb/Mail"
#  endif
#else
# if defined(SYSV) || defined(DGUX) || defined(HPUX)
#  if defined(M_XENIX) || defined(__FreeBSD__)
#define DEF_MAILREADER  "/usr/bin/mail"
#  else
#   ifdef __sgi
#define DEF_MAILREADER  "/usr/sbin/Mail"
#   else
#define DEF_MAILREADER  "/usr/bin/mailx"
#   endif
#  endif
# else
#define DEF_MAILREADER  "/bin/mail"
# endif
#endif
 
#define MAILCKFREQ      50
#endif  /* MAIL */
Regarding  Matthias Buecher's comment of 2001-07-30 03:30:

It shouldn't be all or nothing.  I want to have multiple mail user agents
installed on my machine: I need them for different accounts, or for different
capabilities used at different times.

I typically have several email accounts, and I actually find it worthwhile to
have several mail user agents, each configured to a variety of different mail
accounts.

For example: I am now trying out Mozilla once more.  One day I look forward to
importing all my email from Eudora into Mozilla, but that's not for today. 
Today, I would like to have Mozilla handle my spam mail account since I suspect
that Mozilla's security will be better than Eudora's security since Eudora uses
IE to display html email.

So I want ALL mailtos to be handled by Eudora.  I do want Mozilla's email client
installed, and I want to explicitly bring it up to send/respond to mail sent
to/from suspected spamming companies.

It shouldn't be all or nothing.  In short, is there any reason that Mozilla
doesn't respect it's own setting: "make mozilla the default mail agent: NO"?
this is not installer!
btw I'm pretty sure it's fixed....
not installer -> mail&news
Assignee: mscott → sspitzer
Component: Installer → Mail Window Front End
Product: Browser → MailNews
QA Contact: gbush → olgam
I copy more QA people to find right QA contact.
WFM with Pegasus 3.12c and Moz 2002041203 without Mail/News on Windows ME.
I don't think this is fixed on Linux. On Linux, clicking on a mailto link
without mail/news installed still results in nothing at all. I think there
should at least be a dialog telling the user that mail/news isn't present.
(vaguely remembers this was WFM in browser-only install of RC1 for Win2K. 
mailto: went to Comm 4).
this sounds like unix only. can we change OS to Linux?
This is still a problem on the Win32 platform. I installed from the 1.0 .exe
download with all options. When I click on a mailto link, it opens Mozilla mail
instead of my default (Eudora).
Re comment #32:
that is bug 11459, a solution is provided there and in the FAQ
OS -> Linux
OS: All → Linux
*** Bug 144828 has been marked as a duplicate of this bug. ***
Keywords: nsbeta1
If this is now WFM in Win and Mac, then I suggest creating a new bug for just Linux.

This will keep the confusion to a minimum because I think UNIX has issues that
need to be tackled separately. It also keeps the drift low when people do things
like what I'm about to do:

UPDATE: Mozilla 1.1/WFM, Win2K.
However, it seems that two compose windows appear in Nav 4. I tested IE 5, and
it behaved normally, producing one window.
QA Contact: olgam → esther
Mail triage team: nsbeta1-
Keywords: nsbeta1-
Keywords: nsbeta1
CONFIRMED: Linux-only, Mozilla 1.3b

This is actually purely a Necko, protocol scheme handling issue, if installed
w/o mailnews. 

Mac OS is not affected b/c you can't do a non-mailnews install in Mach-O.
Windows works, it launched Communicator's mail module on my Win98.
Linux remains broken because it depends on bug 33282.

This, as far as I can tell, is independent of the usage of:

network.protocol-handler.external.mailto

while mailnews is installed.

If I'm wrong, please let me know.

If you have a problem with this on another platform, verify you don't have
mailnews installed (look in the Window menu), and open a new bug.
Component: Mail Window Front End → Networking
Depends on: 33282
No longer depends on: 11459
Product: MailNews → Browser
QA Contact: esther → benc
Summary: Clicking on a mailto: link doesn't bring up a mail client if mozilla is installed without Mail/News → mailto: link should launch OS mail client when installed Mail/News
linux has no default OS mail client... not sure why this bug is valid,
especially given that it was filed on win98.
GNOME and KDE do have mail-clients (specified by the user), 
and Moz should use them _regardless_ of whether mailnews is installed.
(at least it should be possible to tell Moz to use the system-wide setting)
mailclient should be configurable regardless of wether mail&news module is
installed, and regardless of wether any desktop system is installed.
For GNOME and KDE, do they provide a "launch-default-mail-client" application ?
If launching their default client means mozilla needs to be linked against their
libraries I think it would be horrible for people not using them.
People may want to check out the patch in bug 128668 (and write a similar one
for KDE if they care about KDE).
Depends on: 128668
I think the best solution if you cannot determine which application to
use is to open a dialog box that asks what program to use (preferably
with a "remember and don't ask me again" checkbox.  Doing nothing is bad, IMHO.
(I had broken the summary)

we do do something in linux, we error.
Summary: mailto: link should launch OS mail client when installed Mail/News → mailto: link should launch OS mail client when installed w/o Mail/News
I am still having this problem in Win 2K, and I am running the 1.4 milestone
release of Mozilla, with the Mail Client.  However when Thunderbird hit its
milestone, I switched over to Thunderbird ... however the mailto links still
fireup Mozilla Mail ... and not Thunderbird (although IE does fireup thunderbird
as the default email client)
Re comment 45, you are seeing bug 11459. A workaround are provided there.
-> defaults.
If bug 33282 is fixed now, I think this might actually work on all platforms.
Assignee: sspitzer → darin
Assignee: darin → nobody
QA Contact: benc → networking
This bug must be back, at least with FF 2.0.0.1.  I didn't have this problem with 1.5.x.  Other folks are talking about this same problem at http://forums.mozillazine.org/viewtopic.php?t=511496&sid=58214636af026e08708d08d390729bb0.

As per request by Ben ben.bucksch@beonex.com, opened new report: Bug 368569 : https://bugzilla.mozilla.org/show_bug.cgi?id=368569
regardless of whatever is going on with Firefox in bug 368569, this feature has been implemented for ages.
Status: NEW → RESOLVED
Closed: 21 years ago15 years ago
Resolution: --- → WORKSFORME
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.