Mozilla's HTTP Pipelining doesn't interact well with VersionTracker.com

RESOLVED DUPLICATE of bug 195746

Status

()

Core
Networking: HTTP
--
major
RESOLVED DUPLICATE of bug 195746
16 years ago
15 years ago

People

(Reporter: Joe, Assigned: Darin Fisher)

Tracking

Trunk
mozilla1.4alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pipelining], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

I noticed this for several weeks now but am just getting around to posting the
bug. When visiting the ever-popular Mac site VersionTracker, often the pages do
not render correctly.  The images will appear mangled or misaligned, and hitting
Reload only makes it progressively worse. Sometimes the style sheet doesn't seem
to load, and clicking on linked images will sometimes yield just the same GIF
image that was clicked instead of the intended page. This is one of the few
sites where I have to switch to another browser to make use of it.

Reproducible: Sometimes

Steps to Reproduce:
1. go to http://www.versiontracker.com/macosx/
2. Sometimes page does not render correctly
3. Sometimes links yield single gif images instead of the intended page

Actual Results:  
broken layout, strange image behavior

Expected Results:  
render page correctly

Comment 1

16 years ago
Joe, VersionTracker.com doesn't interact well with Mozilla's (and Chimera's)
experimental HTTP Pipelining feature. By any chance, did you enable that by
editing your prefs.js or user.js file?
(Reporter)

Comment 2

16 years ago
Greg, I think this is it. I opened up prefs.js and saw that pipelining was
enabled. Turned it off and Versiontracker works just fine now. Thanks for
pointing that out! -Joe

Comment 3

16 years ago
Reassigning to Browser/Networking: HTTP.
Assignee: bryner → darin
Status: UNCONFIRMED → NEW
Component: Page Layout → Networking: HTTP
Ever confirmed: true
Product: Chimera → Browser
QA Contact: winnie → httpqa
Summary: Layout elements on VersionTracker.com not rendering correctly → Mozilla's HTTP Pipelining doesn't interact well with VersionTracker.com
Version: unspecified → Trunk

Comment 4

16 years ago
May I suggest that the bug gets a new description line to describe the
underlaying problem?

I found several sites which also exhibit this problem (and keep on searching):

http://www.portazul.nl/
http://sibyl-archive.org/siteadmin/  (after redirection and login.. sorry)
   but maybe you can figure out which server (brand and version)
     is causing the trouble?
   --> this one is quite well reproducible
(Assignee)

Comment 5

16 years ago
can anyone repro these problems using a 1.3 beta build or recent trunk build? 
the testcases seem ok to me w/ linux trunk 2003022608.

Comment 6

16 years ago
Yes. Using FizzillaMach/2003022803 with pipelining enabled, versiontracker.com
loads very slowly and the images are mixed up.

Comment 7

16 years ago
The results I get (see comment 4) are using 1.3beta. Sorry for not mentioning
before.

Comment 8

16 years ago
Just remembered that there is a great way to get higher reproducibility:

When going to a site which exhibits this behaviour, click on a site-internal
link while the page is still loading the images. Most of the time, I get an
image instead of the page which the link referred to.
(Assignee)

Comment 9

16 years ago
erik says via email that he can repro this on linux.

can someone please capture a HTTP log demonstrating this problem?  here's the
steps (for linux w/ bash shell):

$ export NSPR_LOG_MODULES=nsHttp:5
$ export NSPR_LOG_FILE=/tmp/http.log
$ mozilla

now, just repro the bug, exit mozilla, and then upload /tmp/http.log to this bug
report.  thx!
Status: NEW → ASSIGNED
OS: MacOS X → All
Hardware: Macintosh → All
Whiteboard: [pipelining]
(Assignee)

Comment 10

16 years ago
actually, following the advice of comment #8, i can now repro this as well. 
very unusual behavior.
Target Milestone: --- → mozilla1.4alpha

Updated

16 years ago
Severity: normal → major

Comment 11

16 years ago
Netcraft says VT's running Apache/1.3.24 (Unix) mod_fastcgi/2.2.12 on an unknown
platform.

Comment 12

16 years ago
*** Bug 192771 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

16 years ago

*** This bug has been marked as a duplicate of 195746 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.